After years of developing on Windows (.NET) I kept hearing about all these new kids on the block using Ruby and Python. Since I wanted to try them I thought it would be nice to check out Linux at the same time. I heard a lot about Ubuntu so I am running Ubuntu 10.04 with VMware.

Everything worked supprisingly well and I didn't have any big problems until I tried browsing some webpages with Ubuntu. It feels like I am browsing the web without my glasses or that I am back on my old CRT monitor.

Example 1

enter image description here

This is Windows Chrome vs Ubuntu Chrome. As you can see the Linux version is a little more blurry and the AA isn't that crisp. I did search Google a bit and found a lot of posts that said to edit the fonts.conf file but that doesn't seem to change anything. I also tried changing the rendering modes (Monochrome, Best shapes, Best contrast and Subpixel smoothing) but that didn't help either.

Since I might be doing some web development with Linux in the future it's fairly important to me that the fonts look the same as in Windows.

Example 2

enter image description here

I'm not sure that this example has anything to do with AA - it seems that the font is just smaller on Linux.

Edit: I remember reading that Safari had font problems too. I found these two blog posts:


I wonder if Ubuntu is 'respecting' the grid as well and if I can turn this off.

  • 2
    +1 for the dancing example 1 - no guessing needed :) – msw Jun 30 '10 at 18:33
  • "Since I might be doing some webdevelopment with Linux in the future it's kinda important to me that the fonts look the same as in Windows." - I hope you don't mean this statement, if so, you should really read about browser portability as the only constant you can assume among your users is platform inconsistency. Those who are sticklers for per-pixel perfection should be coding 3270s ;) – msw Jul 2 '10 at 8:57
  • Well text readability is pretty important. So if I style a text to be easy readable on Ubuntu I want it to be readable in as much browsers as possible. – Pickels Jul 4 '10 at 5:27

System > Preferences > Fonts > Rendering and Details...

It is the "ClearType" settings for Gnome, the default for which was not right for my monitor.

Added for example 2:

Depending on your X server, it may be declaring monitor size differently, incorrectly, or not at all. Using the non-free nVidia driver 195.36.24, it claims to have (correctly) identified my monitor, resolution and DPI through the magic of HDMI TMDS LMNOPQRST. I do not know if Chrome or X uses this information for font scaling.

  • 1
    (and Ruby is for Python wannabes but I'd never post anything so incendiary here) – msw Jun 30 '10 at 18:44
  • I don't have that Fonts option. I can do System > Preferences > Appearance > Fonts > Details. I guess it's the same. Do I need to restart my Browser when I change something there? Cause I don't see any different when I change smoothing, hinting or subpixel order. – Pickels Jun 30 '10 at 18:46
  • If the smoothing, hinting or sub-pixel options are making no difference at at all, either you have a particularly daft X-server, an inept video card, or - am I reading this correctly - you are running Linux in a virtual box under Windows? If the latter, all bets are off and you are at the mercy of the virtual framebuffer provided by VMWare in which case your Xserver is worse than daft and no reasonable comparison can be made. – msw Jul 2 '10 at 8:53
  • The smoothing, hinting or sub-pixel is changing the font in the rest of Ubuntu except for browsers. – Pickels Jul 4 '10 at 5:25

Look for any file or folder in your home folder starting with '.font'. (For example, ~/.fonts.conf or ~/.fontconfig/). Delete all these files and folders.

Make sure the settings in System > Preferences > Appearance > Fonts > Details are to your likings.

Now close all open browser windows. You might want to log out or (shudder!) restart the computer.

When you log in again, the new font settings should take effect. Due to some strange reason Chromium and Firefox do not immediately respond to font smoothing settings, hence the need to restart these applications.

  • +1 you're right, I was having this problem and so I just remove .font* and now its working again. – killown Sep 25 '10 at 10:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.