1

On my brand new laptop I am trying to disable some Windows shortcut Win-S, Win-D, Win-C and Win-X like I usually do on all my other computers. Only this time, the Registry entry HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion is missing.

The usual process would be to add DisabledHotkeys StringValue in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced with any letter as the value. I tried to create these entries manually then rebooting, but it doesn't work. Am I missing something?

td;dr HKCU\Software\Microsoft\CurrentVersion is missing from the Registry on my brand new laptop.

Dell XPS 15 9500 (2020), Win10 OS Build 19041.508

5
  • It is in Microsoft\Windows\CurrentVersion
    – John
    Sep 23, 2020 at 22:21
  • 3
    I’m voting to close this question because the author has indicated they have already solved their problem y running the registry editor has the appropriate user with elevated permissions
    – Ramhound
    Sep 23, 2020 at 22:31
  • If you mean below registry entry: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    – eve wang
    Sep 24, 2020 at 5:47
  • You can post that as an answer to your own question, for others to find.
    – Dagelf
    Sep 24, 2020 at 12:49
  • 1
    Dear close-voters: I’m all in favor of closing questions that are founded on (pardon the terminology) stupid misconceptions and typos, like «I typed registryedit and the computer said “'registryedit' is not recognized as an internal or external command, operable program or batch file.”»   I don’t see this as a stupid misconception.   The fact that the user has answered their own question is not a reason to close. Sep 25, 2020 at 21:11

1 Answer 1

-1

Fixed it by running Registry Editor as Administrator. Some entries were hidden.

9
  • Is this even possible? The registry editor will not run unless it is elevated. Something else occurred here. Sep 25, 2020 at 16:03
  • @SeñorCMasMas: Huh? I don’t have access to a Windows 10 machine ATM, but the registry editor has always worked in non-privileged mode before. Yes, of course you need elevated privileges to modify HKLM, HKCR, etc., but you normally have full access to HKCU. Sep 25, 2020 at 21:19
  • @Scott, technically you don't need rights to HKCU.. you are right. But the MANIFEST embedded in regedit.exe says that it requires elevation unless something has changed since I last tried. Try opening regedit.exe without admin rights and TELL ME WHAT HAPPENS before telling me I am wrong. See this post also. And no, it hasn't always worked in non-priv mode. Sep 26, 2020 at 21:26
  • @SeñorCMasMas: Well, I did try it before posting the previous comment.  But I just did it again, to double-check.  Running Windows 7 Professional (yeah, I know), with default UAC configuration, logged in as my ordinary, non-admin user.  Last time I ran it from the Start Menu; this time I ran regedit from a (non-elevated) Command Prompt.  (CMD immediately issues another prompt, as is typical when you invoke a GUI program.)  Either way, “Registry Editor” window opens (no UAC dialog), showing the last key (in HKCU) that I edited.  … (Cont’d) Sep 27, 2020 at 4:32
  • (Cont’d) …  I verified that I can still create, modify and delete values in that key, and create and delete new keys, without providing admin credentials.  Also I could access and modify HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced.  Then I randomly chose a key under HKLM and verified that I could not make write there. … … … But also, I clearly remember several years ago (probably between 2005 and 2009) being similarly able to run regedit (and regedt32) at work on machines where I didn’t have admin access.  (I don’t specifically recall the Windows version(s), … (Cont’d) Sep 27, 2020 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.