0

I’ve enabled the win32time service to host an NTP server on a machine with two NICs. Each NIC is on a different network. I can query the time server from one of the networks, but not the other. Can I do something to make windows broadcast the NTP server on both NICs?

1
  • I'm not sure how to set the IP that Windows listens on for NTP traffic, but try setting it to 0.0.0.0 and see if that works.
    – LawrenceC
    Sep 23, 2020 at 23:18

1 Answer 1

0

I think the problem does not come from the NTP server itself. It should come from the configuration of NTP Client.

On the client computers from the network that could not query the time, open the specific group policy and browse to following entry

Computer Configuration\Administrative Templates\System\Windows Time Service\Time Provider\Configure Windows NTP Client

Enable this policy and input your NTP server's domain name or IP address (you can input both NICs'IP) in NtpServer section. Each NTP server should be separated with comma. And you need to add "0x1" to the end of the line.

If the client computers are domain-joined, you could deploy domain policy to apply this to all the client computers in that network.

Please note: you need to run "gpupdate /force" on all the clients and manually reboot them to make the group policy take into effect.

Thanks,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.