5

Some superuser answers and many other Google hits show that setting link to 00 00 00 00 for the registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ will stop concatenating the suffix - Shortcut when shortcuts are created.

I'm using Windows 7 and this has not worked for me. I have tried

  • manually setting the key,
  • using Ultimate Windows Tweaker
  • and running a .reg file,

but none have worked.

I have set the value, created the shortcut, noted the - Shortcut suffix and checked that the regkey value was still 00 00 00 00. The value persists across reboots. Could all those references really be wrong, or am I missing something?

4 Answers 4

5

It seems that a reboot was all that was necessary for the tweak to start working. Indeed, setting the value to 00 00 00 00 did it. Maybe a reboot was more than necessary, and just killing and restarting explorer.exe would have done it.

1
  • @Tim_Partridge Mark your answer as accepted. This way other users can see that an official answer exists
    – evan.bovie
    May 25, 2011 at 21:09
3

The procedure as described above with setting the String Value of Link to all zero did not work for me. Even after restart, the suffix - shortcut was still there. Sometimes, it also happened that the Link String Value was reset to e.g. 16. However, I found an alternative that worked for my Windows 7 Ultimate 64 bit. Here is the trick:

  1. Open the registry editor: Start Menu » Run » regedit

  2. Save (export) a copy of the current registry – just in case of a mistake. Best is to save it on the desktop and give it a name with the date and some explanation that describes when you saved this copy (e.g. "20120319 registry before removing shortcut suffix")

  3. Then, you navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\

  4. If there is a key called "NamingTemplates" already, then you may enter a new string value directly and skip the next step #5.

  5. If there is no such key called "NamingTemplates", create this key under the above path. To do so, left-click on "Explorer" in the above path, then right-click in the right half of the window and select new >> key. Rename the key to "NamingTemplates". The complete path is then: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\NamingTemplates

  6. Now, under the key "NamingTemplates" you create a String Value with the name "ShortcutNameTemplate" (without the quotes). To do so, left-click on the key "NamingTemplates" and then make a right-click in the right half of the window. Select new >> string value. Rename the String Value to "ShortcutNameTemplate". For this, you need to right-click on the String Value and select >> Rename.

  7. Then, you right-click once again on the newly created String Value, select >> Modify and enter the value "%s.lnk" (again without the quotes).

  8. Exit and close the registry editor

  9. Then, for the change to take effect, close the Exit Windows Explorer and open it again. Now, the "-shortcut" suffix is gone.

Here is also the screenshot how it should look like after the changes: Registry after the changes to suppress the "-shortcut" suffix in Windows 7

If later on, you need to reverse the change:

  • If you had to create the key "NamingTemplates" -> then, just delete this key to make the change undone
  • If the key was already there, then you should set its value back to the original value, before the change (i.e. you should keep record...)
2
  • There's an error here. You wrote ...setting the String Value of Link.... The "string" data type is wrong. Instead Microsoft says that the Link value must be of type REG_BINARY. Just tested it. Works. Jun 7, 2016 at 11:00
  • Is there a placeholder for the file / folder name without extension? I would prefer to have a link named "Document" instead of "Document.odt" for example. String worked for me.
    – Vince42
    Oct 26, 2017 at 22:08
2

Restarting Explorer is sufficient, there's no need to reboot.

Open the Start Menu, find a blank area and press Ctrl + Shift whilst right clicking there. Choose the Exit Explorer option.

1
  • For the record: in earlier Windows versions, close Explorer through Start - Turn Off (or Start - Shut Down), then hold Ctrl+Alt+Shift and click Cancel.
    – user1686
    May 26, 2011 at 16:47
1

The Windows Club's Ultimate Windows Tweaker (direct or via search) did the trick for me on Windows 7 Professional 64-bit. I simply checked its Remove "-Shortcut" suffix for new shortcuts option under Additional Tweaks.

2
  • True, @sim: I updated my answer to at least deal with the possibility that the specific, direct link I provided to UWT no longer resolves. Of course, if UWT simply isn't available at some point, there's not much that will help the answer stand on its own.
    – J0e3gan
    Apr 20, 2013 at 4:48
  • 1
    Agreed, but at least now it's a little more substantial an answer. Thanks for taking the time to enhance it!
    – slm
    Apr 20, 2013 at 4:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.