1

I've resized my main partition on a Windows 10. The Pc is a Dell Inspiron 14.

I've used diskmgmt.msc

So far, so good as you can on the picture below

enter image description here

There is a free space, 224Gb almost, non-alloué means non allocated.

However, as you can see, everything is on Disque 0 meaning Disk 0. When I'm trying to install a linux distribution, the linux distribution does not see any free space, worse it does not see the disk.

My aim is to have Linux see that free space and start the install.

Update 1


After some talks in the comments, please find the screencaptures I did. No other partitions are showing up, except my usb key seen as sda.

With the lsblk

enter image description here

And now enter image description herethe fdisk

enter image description here

enter image description here

I did a fidsk -l and here is the result

enter image description here

Update 2


As asked, please find the screencapture of my controller

enter image description here

  • 2
    The point of view of Linux (or Linux installer) will be useful. Can you get to a console and run lsblk, gdisk -l /dev/sdx (or fdisk -l /dev/sdx)? (replace x with the right letter: a, b or so). Use sudo if needed. Please edit and post the output. Alternatively a screenshot (or a photo) of the installer when it shows you the disk(s). The latter may not bring much data, but it's a start. – Kamil Maciorowski Sep 28 at 12:53
  • Hi @KamilMaciorowski, not sure. I've tried to start a console but nothing is appearing. From the Pop OS's perspective, it only shows my usb key. I'll take a picture after my meeting. – Andy K Sep 28 at 12:57
  • @KamilMaciorowski, please have a look when you can. – Andy K Sep 28 at 14:21
  • 2
    I guess the Linux installer misses a driver proper for whatever controller you connect the disk to. How is the disk connected? – Kamil Maciorowski Sep 28 at 14:28
  • @KamilMaciorowski it is locked inside of the computer. As it is a brand new one, I'm not willing to open it up right now with the screw drivers and etc. – Andy K Sep 28 at 14:34
1

After many tryouts, I found out what was causing the issue.

It was due to an option in the bios called Rapid Storage Technology. That option when activated was preventing the hard drive to be seen by the linux distribution.

I found out that, when I tried to install another linux distribution, Ubuntu.

Ubuntu gave me the correct diagnostic.

After the deactivation of the option, the hard drive is now seen by the distribution.

| improve this answer | |
  • Does the solution affect Windows in a significant way? What are your observations? Answer upvoted anyway. Well done. – Kamil Maciorowski Sep 30 at 6:09
-2

Your disk is most likely formatted as master boot record (MBR), since it's not large enough to require GPT.

MBR can handle at most 4 primary partitions, so you have reached the maximum number of primary partitions that are possible for MBR.

For adding one more partition, you will need to delete one of the existing partitions, in order to make room for the new installation.

I would guess that the space you have made available is inside an extended partition, so is not seen by the Linux installation.

| improve this answer | |
  • 1
    -1. The screenshot shows 5 primary partitions already. – Kamil Maciorowski Sep 28 at 13:34
  • @KamilMaciorowski: Most likely there are actually 3 primary and one extended partition containing the nested logical drives that you're seeing. This explanation fits both the image and poster's experience. – harrymc Sep 28 at 14:06
  • There's no extended partition visible on the screenshot, though. – gronostaj Sep 28 at 14:11
  • No. Near the bottom of the screenshot there is a description, color mapping. There is "unallocated" and "primary partition" there. For "extended partition" and "logical drive" Windows uses different colors and the terms appear in the description if needed. Compare the screenshots here. – Kamil Maciorowski Sep 28 at 14:12
  • hi @harrymc, thank you for your comment. As Kamil asked, I've took some screen captures. Please have a look on my post. – Andy K Sep 28 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.