13

Using Win7-32bit and Powershell ISE I tried to run a just saved script (let's say containing a simple cls). I got the error, that execution of scripts is forbidden with the usual "get-help about_signing" advice.

When using "set-executionpolicy remotesigned" to solve I got a dialogoue to verify whether I'm sure. But if I accept another error comes up:

acces to registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell" denied
    + set-executionpolicy <<<<  remotesigned
        + CategoryInfo          : NotSpecified: (:) [Set-ExecutionPolicy], UnauthorizedAccessException
        + FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.PowerShell.Commands.SetExecutionPolicyCommand

What shall I do, to run saved scripts as user (or automatable as dayly service)?

13

You need to run powershell as an administrator to set the execution policy.

Once you've set it to remotesigned, you can run powershell as a regular user.

  • 1
    I ran PowerShellISE as admin... – mbx Jul 1 '10 at 14:41
  • 5
    He means that you need to run in an elevated prompt. You can right-click on the PowerShell icon in the task bar or start menu and select "Run as Administrator". – JasonMArcher Aug 11 '10 at 16:57
7

Just go to the controll panel -> administrative tools -> Windows PowerShell Modules (opens a powershell) and type the usual "set-executionpolicy remotesigned". That's it.

0

I found the solution by adding the permissions directly to the windows registry.

Wrote about it here: Powershell 101

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.