So, I am in the process of trying to configure some encrypted USB flash drives for some of our users who take some of our more sensitive data away with them. Budgets are tight so I thought TrueCrypt would be awesome as its free, fairly decent by all accounts and a tough nut to crack.

Thought I would create an encrypted container file on the 4GB USB disk leaving about 350 odd megabytes for other files. Created the container called "Files" using the Volume creation wizard. Entered the passwor dto use, generated the random pool of data and formatted the disk. I then added the TrueCrypt travellers disk files using the option. Exited True Crypt and safely removed the disk. Plugged it back in, selected a drive letter and click automount. Entered password and all it says is "Incorrect password or no TrueCrypt volume found!".

Have been puzzling over this for awhile. Tried as many fat handed combinations of the password i selected just incase (including several million myriad of caps lock variations :)) but to no avail. I tried the "Select File" option thinking I could point it towards the "Files" container but browsing the USB drive draws an absolute blank for that file. Have I totally buggered the drive as I was thinking I will just format and start again but windows only sees the 350 MB leftover and not the 3GB encrypted bit. I admit I have yet to get all command line or linuxy and try and fdisk it in to submission.

Any help?



EDIT UPDATE: I have tried using a linux boot recovery (from Ultimate Boot CD) and fdisk as well as diskpart but none of the above can see anymore than the 300MB bit of the disk. Is there anyway to manually erase the partition table and replace with one from another similar USB stick perhaps?

  • Just a question: Did you ever try deleting the file? – Hello71 Jul 13 '10 at 20:18
  • if only it was that simple :) The problem is there is no file to delete. It is as if it has created a hidden partition regardless of the settings I have picked going through the wizard – Tim Alexander Jul 14 '10 at 8:18
  • Have you gone into Disk Management and checked if the drive only has one partition? – Hello71 Jul 14 '10 at 19:45

If you can see your "file" container in Windows Explorer, then you have a file container. If you can't, but Windows only sees the total capacity (not free space, but capacity) as 350MB then you have a volume container.

In either case, delete the container / re-partition (using Computer -> Manage -> Disk Management) and start again. Only this time, create a test volume that is smaller (to save time) and with a really easy password. And recreate your traveler disk.

I have cmd files on my 250GB truecrypt external disk that mounts the volume (because not all Windows systems will autorun). Create a file called truecrypt mount.cmd and enter this into it (with appropriate modifications for you):

start .\truecrypt\TrueCrypt.exe /q background  /v truecrypt.tc /m rm /e

start makes the black command window disappear right away.

.\truecrypt\TrueCrypt.exe is the path to the truecrypt traveler file, in my case, it is in a folder called truecrypt under the root of the drive (it might be different for you).

/q background makes the truecrypt icon appear in the task tray

/v truecrypt.tc is the file container to mount (it will probably be different for you)

/m rm tells truecrypt to mount the volume as a removable drive

/e opens an explorer window in the mounted drive

| improve this answer | |

I don't use TrueCrypt, but this is apparently an unacknowledged problem that has to do with auto-mount on a removable disk.

From this thread :

I've been playing with TrueCrypt. It's very snazzy. I think I will start using it a lot. However, I have it set to auto-mount on logon and it gives me the prompt for my password. When I put it in, I invariably get: "Incorrect password or no TrueCrypt volume found". if I use the same pass after manually loading and mounting, it works fine. I did try selecting to save history of volume information, but it still cannot find the volume by itself...

So it seems like it should work with manual mount, but not with auto-mount.
This is easy enough to verify.

If this is indeed the problem, you should launch a query on the TrueCrypt Forums regarding the use of auto-mount on removable disks. In the meantime, you might use a script for mounting the encrypted volume (provided that it is indeed mountable and that my analysis is indeed relevant).

| improve this answer | |

I ran through the exact steps which you specified in your problem and wasn't able to duplicate the bug. Is it possible you selected a hidden truecrypt volumen or used volume encryption? The automount didn't work for me either so I had to select the file on the usb drive manually and type in the password.

I would recomend using select device rather than select file and see how that handles this. It could always be though that the USB drive died, I know it's unlikely but possible.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.