1

Windows Terminal has a strange relationship with the mouse that I don't understand, and that I want to disable:

  • right-clicking to paste text will instead copy garbled characters in the command prompt
  • in vim rather than pasting it will switch me to "(insert) VISUAL" mode.
  • When using tmux panes I won't be able to select text from a different pane.

How can I disable all these settings so that the mouse doesn't interact with the unix programs and cause eratic behaviour? Basically I want Windows Terminal to behave like putty as far as the mouse is concerned (I just want to use the mouse to select text and right-click to paste).

EDIT: I've noticed that I can achieve the desired behaviour by holding down shift while dragging to select text in the terminal. This has the desired effect. How can I make it so it always behaves like this, rather than having to press shift?

1

So I actually had the same problem with the Windows Terminal and its weird interaction with tmux. Turns out that tmux itself had to have mouse-mode enabled in order for it to work properly with panes (C-b + m).

As for vim, I'm not sure what the problem is: left-clicking will select and copy, and right-clicking will put you into INSERT mode and paste (if you're in a tmux session, Shift + right-click is your best bet).

My WinTerminal has these options in regards to the mouse:

// If enabled, selections are automatically copied to your clipboard.
"copyOnSelect": false,
// If enabled, formatted data is also copied to your clipboard
"copyFormatting": false,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.