1

I can not kill firefox.exe which appears to be running having some kind of problem. I tried taskkill and the solution in a prevous answer, but as one of the comments says

When I call terminate it returns { ReturnValue = 2; }; and the process continues uninterrupted.

And another comment (where I tried the same thing and had the same problem with an elevated command prompt):

I had the same problem with vmware-vmx.exe, and this method did not work either. The return value was 2. I also tried "delete" instead of "call terminate", but it said "Access denied".

So I would like to know how to terminate a process Task Manager, taskkill and apparently wmic wont kill?

1

When you absolutely must have root access to a Windows OS you can use the SYSTEM account.

  1. Open cmd.exe as Administrator
  2. Elevate to the SYSTEM user using psexec.exe -i -s cmd.exe
  3. Now kill with the power of SYSTEM taskkill /F /IM firefox.exe

Note: PsExec is a tool written by Mark Russinovich (included in the Sysinternals Suite) and can downloaded here.

UPDATE: This has been an issue for many people in the past. It might be a problem with FireFox itself or an extension. Please update to the latest version of FireFox and Windows then reboot.

After that you can use the FireFox crash reporter to report the issue to the Mozilla development team: https://developer.mozilla.org/en-US/docs/Mozilla/How_to_report_a_hung_Firefox

  • Thank you for your reply. Same result as normal taskkill unfortunately ERROR: The process "firefox.exe" with PID 13872 could not be terminated. Reason: There is no running instance of the task. This error is what I believe prompted the previous question this post is based on. – The Floating Brain Oct 2 '20 at 22:09
  • 1
    So this is common issue if the task is waiting for some external thing that never returns. The only way out is for that function to return, which it won't, or reboot. I updated my answer with instructions for reporting this to Mozilla because it has to be fixed on their end. – HackSlash Oct 2 '20 at 22:19
  • It is still there on reboot, I am thinking something must be starting it but I see nothing related to firefox or Mozilla in services or in startup on msconfig or task manager. And I am pretty sure it is not a virus masquerading as firefox. Thank you for the link. I dont know if this information helps but the crash reporter says it cant spawn a thread off of the main process. I tried uninstalling but the uninstaller crashed. Re-instillation appears to have failed too – The Floating Brain Oct 3 '20 at 20:48
  • UPDATE I tried using this answer superuser.com/questions/1010345/… to find firefox's startup task. I killed both but its still running on boot! Always at the same PID, seems suspicious ibb.co/89k0d9j . Firefox cant start even after re-instillation. It is located in C:\Program Files\Mozilla Firefox\tobedeleted – The Floating Brain Oct 3 '20 at 21:10
  • 1
    If you can't uninstall, the Geek can: geekuninstaller.com – HackSlash Oct 5 '20 at 15:29
1
  1. in the windows search bar search for control panel
  2. goto uninstall program under Program
  3. uninstall Firefox
  4. press the windows key + r
  5. in the box type regedit
  6. under HKEY_CURRENT_USER search for the software directory
  7. then, look for the Mozilla directory and right click it then click delete
  8. reboot your system
  • If you can't uninstall it first delete it from the registry then, try to uninstall it. – grayhat Oct 3 '20 at 23:36
  • I wound up solving the problem another way, thank you though. – The Floating Brain Oct 20 '20 at 17:57
0

This does not fully answer the question, I don't know if grayhat's second answer or HackSlash's suggestion fixes it or not. However I did solve the problem it was causing, I booted into safe mode, which does not allow any extraneous programs to start, then I uninstalled firefox (and reinstalled). I am not marking this as answer because it does not answer the main question (if someone comments that grayhat's or HackSlash's solutions work, I will mark that as answer), but I wanted to leave this here for anyone who has this problem.

Thank you to a user on Mozilla's help forum

-1

On Windows open task manager then, right click on the process you want to kill, instead of clicking on end task, click end process which should kill the process immediately. This has happened to me plenty of times and I would click end task and the process wouldn't die so, I right clicked and saw end process and it worked every time unless it was a virus or something. If this doesn't work goto add or remove programs and uninstall firefox then,

1). Press the (windows_key + r) on keyboard and type regedit in the box

2). On the left side goto I believe it's USER_HEY or something to that degree. Scroll down to the software folder and expand the folder and right click on the the firefox file and click delete in the popup menu.

3). Restart your computer

4). After bootup redownload firefox, open it and try to see if you can kill it.

The first 3 steps usually helps me to get rid of viruses that may be affecting one or more files on my system because, some viruses like to live in the registry. Step 3 will ensure that the settings and uninstallations have taken place.

  • There is no end process, but there is "end process tree" which I did try, same result as ending a task sorry :( . I think you may be reffering to USERS_HKEY, but there is a lot to search there. – The Floating Brain Oct 2 '20 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.