0

I have been attempting to wipe and reinstall Mint Linux on a Dell XPS-13 ultrabook laptop. I like to completely obliterate data on the drive between installations, for security, and to start from scratch. Unfortunately I have gone and gotten my mSATA drive (a Crucial M500 480GB) into a pickle.

I used these instructions to add a password to the drive, which is a precondition for using a disk erase command. So, I did exactly this:

sudo hdparm --user-master u --security-set-pass foobar /dev/sda

I was about to issue the --security-erase-enhanced command, and then I realised I was in an OS that relied on this drive (including swap space), so I decided to reboot to a copy of Linux Mint on a USB stick. Unfortunately, not continuing with the erase at this point was a mistake.

I now:

  • am asked for an HDD password when I boot the computer, at the Dell/BIOS level
  • have found the password set above, "foobar", does not work
  • cannot use F2, F12 or escape to get to the BIOS before the HDD password is requested
  • cannot boot from a USB stick

However, I have been able to physically remove the the mSATA drive, and then boot from a USB stick. So the computer works fine, it's just the drive that is failing.

I have read these posts:

These, and posts like them, indicate that one should try this or that command, but that is not possible for me - the ultrabook co-operates with the disk password lock so that I am locked out of the whole computer while the mSATA is in place. I cannot boot from another device.

I am certain I am getting the password correct, and it is not accepted. If I try three times it locks the computer up until it is rebooted. I do not believe that I can boot from USB and then insert the mSATA drive - it is not designed to be hot-plug like a USB drive, and I suspect that action would fry something.

There is some chatter around the web about finding master passwords for the drive (by brand and/or model) but I can't find anything for Crucial. It is not clear whether the BIOS is asking for a master or a user password.

I think the computer is fine, and I could just buy a new SSD drive. However, I suspect the existing one is fine, and I just need to know how to reset it. I don't want to keep the data on the drive, and indeed I want to do a complete reset.

What can I try next? I am willing to buy a USB mSATA caddy, but I have seen warnings around the web that hdparm commands can't be used over USB.

  • Do you have access to another PC with mSATA? It might let you boot to some temp OS and format it properly, then you can start over on the ultrabook. – Christopher Hostage Oct 6 at 23:17
  • Good idea @ChristopherHostage - I will give that a go. I have a later model of the XPS-13, but my worry would be that the boot mechanism finds the locked mSATA and then insists on a password, even though that is not the boot device. – halfer Oct 6 at 23:22
  • @ChristopherHostage: I removed the case to the other machine, and found it uses NVMe and not mSATA - I didn't know this was a different size and connector. I therefore do not have a second mSATA-compatable machine. Is the mSATA caddy my next best approach, even though there are some notes on the internet that this might not work, depending on whether one buys a reputable brand or a cheapo no-name item? – halfer Oct 7 at 0:24
  • I am not certain if it would work, but I don't think it would make a difference which USB mSATA adapter was used. It might be useful to reset the BIOS settings. It's always possible that the mSATA drive has failed in this midst of all of this. Sorry I don't have certainties to offer. – Christopher Hostage Oct 7 at 18:47
  • @ChristopherHostage: no worries, thanks for your advice. I am less in a rush than I was yesterday - I have two XPS 13 laptops, and the cause of my problem was that the newer of the two laptops failed, and would not boot up. The old one was in a usable state, so I got it backed up several times, and tried to wipe it so it could be reinstalled, and then I managed to get it into a worse pickle with this password thing. Thankfully I have been able to fix the boot process on the first laptop, so I now have at least one functioning laptop. – halfer Oct 7 at 18:58
1

An mSATA USB 3.0 caddy was the answer here. I booted from a live Mint USB stick, and then plugged in the mSATA device once the computer had settled down.

I ran this information command to confirm the drive was locked:

hdparm -I /dev/sdX

I then confirmed that I could remove the user-level password, and then ran the information command again to confirm:

hdparm --user-master u --security-disable foobar /dev/sdX
hdparm -I /dev/sdX

Finally I followed these instructions to reset the drive:

hdparm --user-master u --security-set-pass foobar /dev/sdX
hdparm --user-master u --security-erase-enhanced foobar /dev/sdX

(If you are copying these commands, swap /dev/sdX for your real drive, and please do triple-check using your Disks utility that you are using the right drive reference - this set of commands is completely irreversible).

It looks like my Dell laptop scanned all drives for "locked" status, and demanded a password even if there was a valid boot drive in the sequence before the locked drive. I suppose ultimately this is an anti-theft measure, intended to make it harder to sell a stolen laptop in a pawn shop. I am in two minds about this - it defeats thieves who have a casual understanding of technology, but it was hardly difficult to get around it.

Unfortunately, the password it required was not the one I set - I set the "user" password, but I guess it wanted the "master" password, which I do not have. Perhaps if I had spent more time searching, I would have found the default master password for Crucial drives of this type.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.