1

As per the subject, I'm having a hard time understanding why what seems to be a default setting in Excel is apparently disabled in the version installed on my work PC. I've tried searching the site (and the web also) for possible answers to my problem, but I wasn't able to find one. I apologize in advance if I have missed it.

My guess is that this issue depends on the Excel's settings of my PC because my colleagues don't have it and also if I use the Excel installed on a Citrix machine I don't have it.

In the following screenshots is what happens when I add data below the existing table (Excel on my PC - sorry for the Italian)

enter image description here

Excel via Citrix:

enter image description here

Anybody knows how to fix this? Thanks in advance!

2

Go to File|Options and select the fourth option, Proofing. The first thing in its settings should be AutoCorrect options. In that, there is a button labeled AutoCorrect Options and you want to click it. A dialogue box opens with four tabs, the second of which is AutoFormat As You Type. Select that and there should be three options you can check or not check.

The thought here is that your SECOND checkbox (Include new rows and columns in table) is unchecked. Check it. Look at the third checkbox as well (Fill formulas in tables to creatre calculated columns). That needs to be checked as well.

If you check the second one but not the third, your table and its formatting will expand for you, but formulas you have in the table and want to fill downward as you add rows... well, they won't do that. So both need checked.

1
  • Thank so much Jeorje, it worked! It was driving me crazy :) I wonder why that checkbox was unticked since Office is installed by our IT and I never mess with the Options ... but I can live with that :D
    – Pesetas74
    Oct 8 '20 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.