0

BLUF: My laptop will not detect the printer on the network.

My laptop is running Windows 10, my router is the Xfinity Xfi router (Model: CGM4140COM), and my printer is a Brother MFC-J6510DW. Both are on the same network (2.4 GHz because of old printer), same subnet (10.0.0.1/24), subnet mask is set correctly (255.255.255.0). Xfinity gateway confirms that both devices are connected to the network, and that the IPs are within the same subnet. Network discovery is on with automatic setup checked and file/printer sharing turned on. Password protected sharing is turned off. Network is set to Private/home. In the Windows Defender Firewall, all File and Printer Sharing Private rules are set to allow and enabled for inbound and outbound.

I have tried setting up the printer both through the Windows Printer installer and the Brother Printing Device Installer. In all cases, the printer is not visible to my laptop. I am currently unable to ping any local IPs as well. Lo address is still able to be pinged.

At this point, I am waiting for a printer USB cable to arrive to attempt installation that way. What else could be the problem though?

  • 1
    Go into the Brother Control Panel, Network settings and give it a static IP on your network. Restart the printer then see if you can see it. You also say "I am currently unable to ping any local IPs " Is your own computer set up properly on this network? – John Oct 9 '20 at 0:03
-1

Try to reset your router to factory and reset up password protected login page and ssid. I would start there first.

Device manager > find your install of the printer > right click > scan for property changes > uninstall and reinstall.

ipconfig /? try the command to renew the IP Address if the aforementioned does not work.

  • This is not a router problem. Both devices are in the same subnet so nothing is being routed through the router (although packets are being switched - this is happening at layer 2, so the router being able to see both devices is proof that its not a router/routing issue) – davidgo Oct 9 '20 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.