0

When bookmarking a URL like:

https://addons.mozilla.org/firefox/addon/youcare-search/

You get this bookmark title:

YouCare - The charitable search engine – Get this Extension for 🦊 Firefox

Then, if you copy and paste that URL title into Notepad++, the non-ASCII Unicode character (a fox, in this example), gets displayed as a box (a rectangle, to be specific).

How do you configure Notepad++ to show non-ASCII Unicode characters like this?


Note: This questions is related, but different than Notepad++ special Unicode characters not displaying properly

That question deals with what is likely a bug in Notepad++ that causes the characters to be displayed differently after the file is saved and reopened. This question deals with characters that do not even appear correctly when pasted into Notepad++.


Update:

I tried saving the above title string as a text file in Notepad++ and then reopened it. No change. I then tried copying the text from Notepad++ into StackExchange (in Firefox), and the text displays correctly in Firefox.

That means Notepad++ is storing the character correctly, but not displaying it as desired.

Using a hex editor, I see the fox character is being encoded as: F0 9F A6 8A, which is as it should be: https://www.unicode-search.net/unicode-namesearch.pl?term=fox%20face

1

While my fox is grey, instead of red, it works for me. I don't have anything special installed. The only setting that I can think that may be different is Encoding -> UTF-8

Check to see if your setting is set to UTF-8 instead of ANSI?

enter image description here

MISC. Settings enter image description here

New Document Settings enter image description here

11
  • Thank you for trying it, DrZoo. And thank you for your screenshot. Notepad++ is selecting UTF-8 for me as well, but displaying very differently. Which font at are you using, and what Notepad++ version, Notepad++ bit-depth (32 or 64) and OS are you using? Oct 12 '20 at 14:11
  • @RockPaperLz-MaskitorCasket I'm using Notepad++ v7.9 (64-bit) (build time Sep 22 2020 - 03:19:04) on Windows 10. Where do you find the font style? I can't seem to find it.
    – DrZoo
    Oct 12 '20 at 14:18
  • Thanks. In Notepad++, you can go to Settings > Style Configurator... to see the fonts. Note that there can be fonts defined for every file type as well as a global override! Oct 12 '20 at 14:24
  • @RockPaperLz-MaskitorCasket Global Styles and Global override, Courier New font. My file extension for my picture is .txt
    – DrZoo
    Oct 12 '20 at 14:34
  • Curious. I tried the Courier New font, and even saved the text as a .txt file. I still just get a rectangle where the fox should be displayed. I'm using the same version of Notepad++ as you, although I am using the 32-bit release of it. The only other difference I can think of is that I'm trying it on a Win7 box. Oct 12 '20 at 14:45
0

In addition to DrZoo's answer, there is a second possibility of where the error comes from: Your curent font does not have a glyph for the fox. Especially since Emojis are new-ish and low on the priority of font-makers, it is quite likely that your font simply cannot provide a symbol, in which case notepad++ defaults to the square you see.

Check what font you have and then verify that it indeed has emojis, or switch to a font known for having them. One of these would be "consolas", which is used here on stackexchange (and given that you do have the fox in your post, we know that it includes the symbol you need)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.