5

I want to install Intel HAXM 7.6.5. If I do this the setup aborts with this error:

The system requirements are not satisfied

In the background you can see the checktool.exe. This is the output:

checktool.exe --verbose
CPU vendor          *  GenuineIntel
Intel64 supported   *  Yes
VMX supported       *  Yes
VMX enabled         -  No
EPT supported       *  Yes
NX supported        *  Yes
NX enabled          *  Yes
Hyper-V disabled    *  Yes
OS version          *  Windows 10.0.18362
OS architecture     *  x86_64
Guest unoccupied    *  Yes. 0 guest(s)

I don't know what the requirements for HAXM are, but it seems that VMX is not enabled. How do I enable it?

Edit:

I checked the system requirements and they are met (Intel Core i7-8700 with Windows 1903). Now I enabled in the BIOS the following settings:

  • Intel(r) Virtualization Technology
  • VT-d
  • TxT

Through this I was able to install HAXM without problems. Don't know why but I would say I tried that before. Perhaps I missed TxT ... Thanks Ramhound.

3
  • 1
    HAXM requirements
    – Ramhound
    Oct 12, 2020 at 17:10
  • 1
    Have you enabled VT-x within your firmware settings? Please edit your question instead of submitting a comment
    – Ramhound
    Oct 12, 2020 at 17:11
  • I’m voting to close this question because the author indicated that VT-x was actually disabled and once it was enabled their problems were solved.
    – Ramhound
    Sep 11, 2021 at 20:03

2 Answers 2

1

I think it's not enough to just enable VT in the BIOS and disable Hyper-V in windows. You also need to disable Hyper-V in the BIOS. The setup misleadingly lets you think it failed because for some other reason, and that its ok with the fact that "Hyper-V-Disabled: No". What it really wants is "Hyper-V-Disabled: Yes" and not just in the OS, also in the BIOS.

Actually, after alot of twiddling, I just got it to work. Use the Windows Search box to find "Turn Windows Features On or Off"

Within it there are several features (Windows 11) relating to virtualization:

  • Guarded Host
  • Hyper-V (careful, upon de-/selection not all sub items get de-/selected even though graphic shows otherwise)
  • Virtual Machine Platform
  • Windows Hypervisor Platform
  • Windows Sandbox
  • Windows Subsystem for Linux

So what I did was fully disable the following:

  • Hyper-V
  • Windows Sandbox
  • Windows Hypervisor Platform
  • Virtual Machine Platform

I'm not sure which of those were actually necessary to disable (I'm sure this would interfere with any VMWare or VirtualBox installation, which I don't use), but it made it work. To be fair, I had previously also performed actions described here:

https://github.com/intel/haxm/blob/master/docs/manual-windows.md#disabling-hyper-v-on-windows-10

But that alone wasn't enough, so I don't know if it is also a requirement. Also note that The Issues section on HAXM's Github Page, describe why HAXM and Hyper-V are incompatible and why Hyper-V has to be fully disabled. There is also talk about WSL2 being involved with Hyper-V, hence HAXM not installing when WSL2 is enabled. I personally didn't need to disable it though.

More importantly, since Hyper-V is sometimes needed, the following page explains then how to deal with this when you need HAXM too:

https://developer.android.com/studio/run/emulator-acceleration#vm-windows-whpx

3
  • 3
    There would not be a Hyper-V firmware settings, because the firmware is not concerned with Hyper-V (or any other application of hardware-assisted virtualization).
    – Daniel B
    Sep 11, 2021 at 15:27
  • 1
    “You also need to disable Hyper-V in the BIOS.” - Hyper-V is a feature of Windows. You are suggesting disabling a ton of helpful Windows features unnecessarily. WSL2 doesn’t require Hyper-V, so those discussions, are invalid or at least inaccurate if they suggest WSL should be disabled. The first inaccurate and completely false statement about disabling Hyper-V in the BIOS is the reason I am downvoting this answer. If you edit your answer and remove the inaccurate information I will reverse my vote.
    – Ramhound
    Sep 11, 2021 at 20:00
  • no don't reverse, just get a hobby. Read the part that says: I'm not sure which of those were actually necessary to disable. The issue here has nothing to do with WSL2
    – mo FEAR
    Oct 28, 2021 at 12:11
-1

I'm also having similar issue and went through the process of enabling virtualization in the bios setup but it still brings up the same error, albeit the only difference in our problem is that my processor is intel core i5

2
  • Please provide additional details in your answer. As it's currently written, it's hard to understand your solution.
    – Community Bot
    Sep 4, 2021 at 21:20
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. Sep 5, 2021 at 5:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.