I'm currently trying to assist in the build out of our Company's app on a 64-bit server, as part of "re-upping" our partnership with Microsoft. To get us to the correct point level, we are trying to install SQL Sever 2008 on Windows Server 2008 R2. But this isn't possible currently. Yes, there is a work around, but for reasons I can't begin to speak to, that work around isn't working. The setupfiles from SP1 are indeed copied to the computer, but when I run the SQL Server 2008 install again, it just gives me the same message about the program having compatability issues, and I am unable to proceed with the install.

Has anyone had any experience with this problem? Is there another way we can get this up and running? A work around for the work around?


Well, it turns out the problem was we had never activated windows. At least, we activated windows and then the workaround started working around.

| improve this answer | |

The compatibility issues dialog should contain a "Run program" button that you can use to force the installation.

After SQL Sever 2008 is installed, installing SP1 should resolve all compatibility issues.

Also see this Microsoft article :
Hardware and Software Requirements for Installing SQL Server 2008 R2
(do you install SQL Server 2008 R2?)

| improve this answer | |
  • No, the run program button doesn't do anything when I click it. Also, this is not SQL Server 2008 R2. It has to be SQL Server 2008, for reasons beyond my control. – peacedog Jul 2 '10 at 14:07
  • @peacedog: Sometimes it helps to set the Compatibility mode of the setup file to an earlier Windows version. – harrymc Jul 2 '10 at 15:20
  • I tried several earlier versions to no avail. – peacedog Jul 2 '10 at 19:39

.NET Framework 3.5 is a prerequisite for SQL Server 2008. It's not installed by default on Windows Server 2008 R2; have you installed it?

| improve this answer | |
  • Well, it doesn't show up in programs and features, but it appears to be there (C:\windows\microsoft.net\Framework\x64\ --> 1.1, 2.0, and 3.5 folders present and filled with all sorts of goodness). I mean, we previously had our company's (.net) app running on the box (it's just that SQL Server 2008 R2 was installed by mistake), so I know .net is alive and kicking. There's so much different in server 2008, so I'm sure there's a reason I am not seeing it in Programs & Features. – peacedog Jul 2 '10 at 18:24
  • @peacedog: There is only one reason for not seeing it in Programs & Features - if it's badly installed. I would suggest to re-install it (uninstall if necessary), rebooting at each step. – harrymc Jul 2 '10 at 19:33
  • @harrymc - it shows up under ServerManager -> Features. I believe it is installed correctly. I might try removing it and then re-adding it, though. – peacedog Jul 2 '10 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.