7

Given a high-throughput network and only 1 or 2 hops between any system, why would the "Securing remote connection" stage be so slow?

Sometimes it looks like the other system is asleep but ethernet power saving is off and it can never fall to sleep because Power Options are set to "High Performance".

What could cause this process to be slow if all network obstacles were removed and systems definitely not sleeping or working on anything?

Also, the domain controller is certainly not overburdened and uses less than 4% of CPU during peak hours.

RDP connection window

4
  • You can capture the traffic on the RDP server host using Wireshark and check if any suspicious network traffic is involved.
    – Robert
    Oct 14, 2020 at 17:22
  • @Robert Yikes! Ok...
    – bluesquare
    Oct 14, 2020 at 17:37
  • I just encountered this situation myself on a local PC where I could see the screen. One situation where the "securing phase" can take longer is if the RDP server PC has just rebooted and has not fully finished this, e.g. the display shows "Please wait" or the system is installing Windows updates. In this situation you can already start the RDP connection, but it will be delayed until the system boot is complete and the local login screen is shown.
    – Robert
    Oct 15, 2020 at 7:05
  • @Robert Good information. The trouble is, the machine in question did not just reboot. Perhaps it's also caused by the first RDP-connection-since-boot but I also believe that it has made connections previously long after any reboot.
    – bluesquare
    Oct 15, 2020 at 13:28

2 Answers 2

3

In case your machines do not have access to Windows Update

One task of "securing remote connection" is to update the root certificate store via Windows Update to be able to verify the certificates used for the remote connection. If your machines do not have access to Windows Update, this task will timeout. Unfortunately, it will not fail immediateley, it will really timeout after about 20 seconds.

If your machines do not have access to Windows Update anyway - not commenting on that - you can disable the automatic renewal of root certificates. You can enroll this setting either by GPO or by local computer policy (open gpedit.msc):

Go to Computer Configuration > Administrative Templates > System > Internet Communication Management > Internet Communication settings and enable the policy Turn off Automatic Root Certificates Update.

1
  • this didn't work for me.. securing remote connection still takes about 18 sec
    – Sybuser
    Sep 16, 2022 at 8:47
0

If your machine does NOT have NLA enabled, you can put this in your .rdp file:

enablecredsspsupport:i:0

and it will connect fast. However, you will loose the capability to send credentials to the remote machine and will need to type your password on logon screen.

It goes without saying that to keep NLA disabled is not recommended.

Trying to do the above on a NLA-enabled computer will reject the connection with the message:

The remote computer requires Network Level Authentication, which your computer does not 
support. For assistance, contact your system administrator or technical support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .