1

I easily installed Windows 10 on a different FreeDOS device before. Booting up the device after plugging in my USB flash drive I right away got to Boot Menu with F12 key. However, in the current case I could not. I recently bought NH.Q7MEY.001 version Acer Nitro 5 laptop with FreeDOS option and want to install Windows 10 on it. Even though I enabled "F12 Boot Menu" pressing F12 key repeatedly to "Boot Menu" does not work. In "Boot Menu" I see only "UEFI_SHELL" option in boot priority section instead of together with my flash drive. Here are pictures of my BIOS screen:

Information \ Main \ Advanced \ Security \ Boot

How do I have to set, if I have to, my BIOS settings to be able to install Windows 10 from my USB flash drive if that is the reason to my issue here? Apart from the main issue I would also appreciate if anyone can recommend me some of the important BIOS features to enable/disable in order to make the most out of my device in terms of speed?

Thanks in advance!

4
  • 3
    Is your bootable flash created "for MBR devices" or "for UEFI devices" (MBR of GPT)?
    – simon
    Oct 15, 2020 at 10:27
  • Bios is obviously setup for UEFI boot. That means the USB stick has to be properly configured for that as well. If it is a MBR only stick it isn't bootable in UEFI mode and you will get teh UEFI shell prompt in stead.
    – Tonny
    Oct 15, 2020 at 10:41
  • I do not recall that exactly. Is there a way to determine this without reformatting the frash drive? @simon From both of your answers reformatting my flash drive properly will solve the issue, I think. I will inform as soon as possible. Oct 15, 2020 at 10:58
  • That solved the issue, but this time there is no drive to select to install Windows 10 on during installation procedure at the beginning. @simon Oct 15, 2020 at 11:39

1 Answer 1

1

Generally speaking, your bootable media "type" should match your firmware, and booting from it should be enabled and available.

For legacy BIOS, you should create MBR-partitioned flash drive. Most UEFI systems, however, are capable of booting from both MBR- and GPT- bootable drives. However, some laptops have some kind of 'stripped down' firmware. Also, Secure boot (if enabled) may restrict booting from removable media, if something goes wrong.

Personally, I've experienced multiple issues when creating bootable media with Microsoft's Media Creation Tool. Instead, I prefer to download ISO only with Media Creation Tool, and then I use Rufus to write it to USB flash - this way you have a bit more options to set:

RUFUS

As for Secure boot, disabling it (at least, during installation process) may solve your issues, at least give it a try to it (consult your UEFI manual how to do it). You may also need to tune additional setting in UEFI.

That solved the issue, but this time there is no drive to select to install Windows 10 on during installation procedure at the beginning

It could be caused either by USB Media/firmware type mismatch, or you may have to set the bootable media directly in the firmware. Also try common keys (DEL, F12, F8, F2, F11 are the most common) for separate boot menu.

It is also possible that USB devices may not be accessible by firmware (check Legacy USB Support setting). Sometimes BIOS/UEFI cannot access a drive in USB hub, so try inserting the USB flash directly to the rear motherboard's ports (on a laptop, try all available ports).

4
  • I recreated the media with the same settings you shared in the picture above except for FAT32 file system. I instead used NTFS file system. Noting GPT-MBR difference my machine is finally able to see my USB flash drive. However, during Windows 10 installation in drive selection step I see no drive even though I have a 512 GB SSD mounted on the machine. I can see the SSD in BIOS settings. I also checked out through Command Prompt tool provided by Windows 10 Installation tool with "list disk" command in diskpart utility. However, there is only one disk, which is my USB flash drive. Oct 15, 2020 at 16:46
  • @BurakKaraosmanoğlu, strictly speaking, this very problem is solved. That one that you described is a new problem (maybe even worth a new question?). As for it, maybe an additional driver is necessary (though unlikely). I would also suggest trying boot to another OS (like live Ubuntu) and check whether you can access the SSD. Also make sure you did not accidentally disable the drive in UEFI (or have some weird setting turned on).
    – simon
    Oct 15, 2020 at 16:54
  • Thank you very much! I will keep in mind your suggestions. Also I agree with you. I will post my new problem under a new title. Oct 16, 2020 at 7:50
  • @BurakKaraosmanoğlu, don't forget to vote the answer up and mark as answered if it helped you :) I will try to help you with your new question as well there.
    – simon
    Oct 16, 2020 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .