I am using win 7 64 bit.

I tried the solution given here, didn't help. David's answer makes me think this is futile. Is there anything else to try?


Notice that I have a graphic card on my motherboard (with 512MB), so in theory, it doesn't need any external memory. Also, notice the BIOS latest update (03/25/08).

From what I can see here, there is a newer version (2008/07/30), but I am scared to use it (since it is "BETA")

Thoughts ?

   CPU Type   DualCore Intel Pentium D 915, 2800 MHz (14 x 200)  
   Motherboard Name   Gigabyte GA-945GCM-S2C (2 PCI, 1 PCI-E x1, 1 PCI-E x16, 2 DDR2 DIMM, Audio, Video, LAN)  
   Motherboard Chipset   Intel Lakeport-G i945GC  
   System Memory   3328 MB (DDR2-667 DDR2 SDRAM)  
   DIMM1: 2048736750L   2 GB DDR2-667 DDR2 SDRAM (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)  
   DIMM3: 2048736750L   2 GB DDR2-667 DDR2 SDRAM (5-5-5-15 @ 333 MHz) (4-4-4-12 @ 266 MHz) (3-3-3-9 @ 200 MHz)  
   BIOS Type   Award Modular (03/25/08)  
   Communication Port   Communications Port (COM1)  
   Communication Port   Printer Port (LPT1)  

   Video Adapter   NVIDIA GeForce 8500 GT (512 MB)  
   Video Adapter   NVIDIA GeForce 8500 GT (512 MB)  
   3D Accelerator   nVIDIA GeForce 8500 GT  

   DMI BIOS Vendor   Award Software International, Inc.  
   DMI BIOS Version   F5  
   DMI System Manufacturer   Gigabyte Technology Co., Ltd.  
   DMI System Product   945GCM-S2C  
   DMI System Version    
   DMI System Serial Number    
   DMI System UUID   00000000-00000000-0000001F-D06D37BD  
   DMI Motherboard Manufacturer   Gigabyte Technology Co., Ltd.  
   DMI Motherboard Product   945GCM-S2C  
   DMI Motherboard Version   x.x  
   DMI Motherboard Serial Number    
   DMI Chassis Manufacturer   Gigabyte Technology Co., Ltd.  
   DMI Chassis Version    
   DMI Chassis Serial Number    
   DMI Chassis Asset Tag    
   DMI Chassis Type   Desktop Case  
   DMI Total / Free Memory Sockets   2 / 0  
  • 4
    Note for those thinking this is a duplicate question, I don't think it is. The question is specifically about 64bit OS, where most questions of this type are about 32bit OSes. Commented Jul 2, 2010 at 15:42
  • We're going to need a lot more information to help you -- at the very least, motherboard make/model/bios version. Commented Jul 2, 2010 at 15:49

6 Answers 6


It's your motherboard that's limiting the available RAM (more precisely it's the Intel 945G chipset).

From Gigabyte:


  1. 2 x 1.8V DDR2 DIMM sockets supporting up to 4 GB of system memory

  2. Dual channel memory architecture

  3. Support for DDR2 667/533/400 MHz memory modules (Go to GIGABYTE's website for the latest memory support list.)

* Due to standard PC architecture, a certain amount of memory is reserved for system usage and therefore the actual memory size is less than the stated amount.

What I'm about to put here is based on personal discussions with Intel technicians about this issue:

Since the chipset can only access 4GB of RAM at most, and you have 4GB installed, the chipset statically maps the I/O devices instead of dynamically mapping them (as it's faster to have it mapped statically). This makes these RAM addresses invisible to the OS, as it's never going to be available.

When the system has less than 4GB installed the chipset dynamically maps the I/O instead, so that it can ensure the most amount of installed RAM is available at any time.

To do this, they need to make all the installed RAM visible to the OS so that it can access any potentially available RAM addresses, regardless of where the I/O is mapped at that point in time.

Since the chipset has to keep track of where the I/O is mapped dynamically, this is slightly slower.

This was a decision made by the Intel design team to ensure top overall 'performance' in both fully populated and partially populated configurations.

To get 'all you RAM' visible, you'll need to find a motherboard with a chipset that supports your 64-bit CPU, and allows more than 4GB of RAM.

Something with an Intel G965 chipset would probably be your best bet. Perhaps the Intel DQ965GF, we used a ton of these and it was a good board. It's slightly outdated these days, but probably still available (as probably are other makes and models with the G965 chipset).

Hope that helps...

  • Sad news for me - but at least I know not to work on it (before upgrading the hardware). Techie - many many thanks for your help!
    – Tal Galili
    Commented Jul 2, 2010 at 23:14
  • NP. :) That was the tipping point generation for desktop 64-bit; so the CPU's had it before the motherboards fully supported the advantages of it (ie: more RAM). Commented Jul 3, 2010 at 4:17

The most likely reason is that the system BIOS won't allow it. There are several things you can try:

  1. Update the BIOS
  2. Look for settings in the BIOS that relate to memory map functionality and change them (one at a time, and only after researching what they mean)
  3. Contact the system vendor

EDIT: Based on your new information about the type of system, I was able to download the motherboard manual from Gigabyte. Unfortunately, it doesn't look like there are any promising settings (some BIOSes have the ability to hide memory above 3.X GB or play other tricky games). There is only one setting that I could see that relates to 64bit: HPET Mode. You might check try changing it to 64bit just in case it adjusts the memory available to the system in addition to changing the CPU timer, but I doubt it is going to make a difference. The website for this motherboard shows that the max supported is 4GB, and has a little note about reserving some for the system, so you might just be out of luck with getting more than what you are seeing.

  • I think I got downvoted as retaliation for downvoting what I believe to be an incorrect answer. I didn't realize it worked that way around here. If this answer is incorrect, please downvote it and let me know what is incorrect. Commented Jul 2, 2010 at 15:49
  • 1
    +1. Not sure what the downvote is for. Often BIOS updates do help.
    – Sathyajith Bhat
    Commented Jul 2, 2010 at 16:25
  • Just in the principle of the thing - I am upvoting this answer. I AM keeping my "answer mark" for now :)
    – Tal Galili
    Commented Jul 2, 2010 at 16:28

In depth explanation here


If the page does not load, see Google's cache of it here http://webcache.googleusercontent.com/search?q=cache:vLYtmlOoQIsJ:www.asisupport.com/ts_4GB_memory_info.htm+asisupport.com/ts_4GB_memory_info.htm&cd=1&hl=en&ct=clnk&gl=us



The <4GB of RAM problem isn't just operating system related.

It could simply be that while the processor and operating system may support more than 4GB of ram the manufacturer of the motherboard did not see it worth the time/effort/cost to connect up enough of the address lines between the processor and memory controller to enable use of more than 4GB of memory.

This gives the same net effect as running a 32 bit operating system but on a 64-bit system, the processor, unable to physically USE any address above 4GB for other hardware or memory devices or even request the memory controller to map up to another address will be forced to kill some of the available memory in favor of things like the graphics card.

This is basically the same problem as with a 32-bit OS, but limited in hardware rather than software. It is more likely to affect slightly older hardware where 4GB would be considered "more than plenty"...

I've seen a number of items about this on the internet where hardware is emulating the 32-bit limit, here, a Dell 530 laptop has the same problem, here, a 945 chipset system with Win7 64, and basically all over the internet.

It's not an easy one to fix, or even one that makes a lot of sense, but it basically boils down to old hardware not being made to physically support what you are asking it to do...

It could be that the BIOS update that you have found might fix the problem, but I wouldn't count on it I'm afraid.

  • So bottom line - I need to upgrade the CPU ?
    – Tal Galili
    Commented Jul 2, 2010 at 16:41
  • 1
    It could be either the CPU or the motherboard itself, or both. It's likely to be at least the mobo and CPU that need to be replaced, the only thing to make sure is that you either get a motherboard that states DDR2 and >4GB support, or just get a DDR3 motherboard, CPU and new RAM. Most newer mobos should not be limited in the way yours is currently.
    – Mokubai
    Commented Jul 2, 2010 at 18:01

This is a long shot, but it could be incompatibility between RAM and motherboard. I've seen cases where motherboard isn't working well with particular type of memory chips.

Also I've seen similar problems in cases where motherboard uses different models of memory chips or different manufacturers.

Also, make sure all RAM is good etc etc.


The reason might be quite simple.

You might have a shared memory video card in your system that takes out the amount (like a built-in video card) of your global memory installed. It's different when you have a dedicated memory video card installed.

  • -1 Almost certainly the wrong answer. Can you name a shared memory card that allows you to configure ~800MB of RAM for it? Commented Jul 2, 2010 at 15:41
  • 768mo video card
    – r0ca
    Commented Jul 2, 2010 at 15:42
  • 768MB on an onboard card? Which motherboard and card? Commented Jul 2, 2010 at 15:45
  • I added the specs of my computer - love to know what you both think.
    – Tal Galili
    Commented Jul 2, 2010 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .