I am trying to remove the file ownership tab in Windows 10 File Explorer. I have unchecked this option in the View pane but after navigating back to the folder or any other folder it comes right back. Is there a registry hack that can be applied to permanently remove this tab?

This is a domain joined machine however and File ownership may be re-appearing due to domain settings that need to be edited local using either gpedit or regedit. Administrator access is held on this machine also.

enter image description here

Similar issue: How to remove 'file ownership' in explorer, win 10

  • After removing the column it should not come back on the same folder (ex: Downloads). File Explorer MAY save custom views on certain folders (right-click folder, Properties, Customize). So you may have to remove column multiple times, otherwise you might be able to go to that Properties, Customize tab, change drop-down to General items & check 'Also apply this template to all subfolders', & click OK. Clicking Options (in top-right), View, Reset Folders may also help
    – gregg
    Oct 15, 2020 at 17:49
  • Is the O.P. still watching? Do all folders force this column on your or just the Downloads folder? Do other folders remember view settings or are they forgotten (especially folders on the Desktop)? Feb 28, 2021 at 6:51

4 Answers 4


Open Windows Explorer, Right click on the area Name, Modified, ... and either Uncheck File Ownership there or select More at the bottom and get the next dialogue window. Uncheck File Ownership there.

This is not a View setting but an Explorer Option setting.

Once done, it will be best to close out, restart and then check the result.

enter image description here

If you this does not work:

(a) Check Group Policies with the Company, and

(b) If need be do a Windows 10 Repair Install

Go to the Media Creation Link:


Windows 10 is running, so click on the Download button (not Upgrade Button) and select Run.

This will launch the Repair and proceed normally.

Start with the option to Keep Everything.

  • Tried that but gives the same result as above. After re-opening explorer or navigating back to the folder the File Ownership item comes back.
    – Pie
    Oct 15, 2020 at 18:00
  • It should work on a good machine. Try the following: Open cmd.exe with Run as Administrator and run in order: dism.exe /online /cleanup-image /StartComponentCleanup then dism.exe /online /cleanup -image /restorehealth and then SFC /SCANNOW .Restart and test.
    – John
    Oct 15, 2020 at 18:04
  • "dism.exe /online /cleanup-image /StartComponentCleanup" completed 100% "dism.exe /online /cleanup -image /restorehealth" error 87 "SFC /SCANNOW" Found corrupted files and repaired them. Rebooted afterwards.
    – Pie
    Oct 15, 2020 at 20:41
  • So then after cleaning up the errors, does Windows Explorer now work for you?
    – John
    Oct 15, 2020 at 20:46
  • No, "File Ownership" keeps returning. I recall there was some gpedit or regedit change that was performed on another machine to remove this setting. I believe it comes coming back due to a domain policy.
    – Pie
    Oct 16, 2020 at 16:11

I had the same problem and none of this worked for me. However I found a solution (for me):

Some time ago I had connected my personal home PC with my work account. After removing my work account I could permanently remove the file ownership column and apply it to all folders. This also removes the File Ownership menu from the context menu of files.

The setting is under Settings - Account - Access Work or School.

Obviously this would not be a valid solution if you need to be connected to your work account...

  • Removing a "work account" may not be a tolerable solution for other users.
    – r2d3
    Feb 27, 2021 at 19:30
C:\WINDOWS\system32>net helpmsg 87

The parameter is incorrect.

You have an extra space in your command between /cleanup and -image.

Click View ribbon, then Options. View tab and click Reset Folders.

This resets folders of that type. To see what types of folders there are paste this into a command prompt.

 (@For /f "tokens=1* delims=" %A in ('reg query HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions /f name /v name /s ^| findstr /c:"Name" ^| Sort') Do @Echo %A) & pause

You'll get a list like this

CanonicalName    REG_SZ    AccountPictures
CanonicalName    REG_SZ    Communications
CanonicalName    REG_SZ    Communications.SearchResults
CanonicalName    REG_SZ    CompressedFolder
CanonicalName    REG_SZ    Contacts
CanonicalName    REG_SZ    Contacts.Library
CanonicalName    REG_SZ    Contacts.LibraryFolder
CanonicalName    REG_SZ    Contacts.SearchResults


You can also do a global reset - type control folders into Run dialog and View tab, Reset Folders.

One other thing to note is that explorer remembers your settings by the path you get there. So opening This PC then C:\ then Windows is a different set of settings to opening explorer at C: drive then going to Windows. If there are no settings Explorer does some search of settings nearby.

  • Yes even going back and folder and then forward a folder is resetting the "view" settings. So doing a view reset actually dosn't change anything. Even after altering the view settings again afterwards.
    – Pie
    Oct 16, 2020 at 16:10

Not exactly a best solution but it's satisfactory to me. Open Explorer, drag the File Ownership column right to the last position File Change Folder and Search Options View Apply to all folders

Now at least the File Ownership column will not bother you much because it will be usually hidden to right and the important columns will be shown anyway to the left.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .