0

I tried installing docker-compose in WSL because for some reason it wasn't working even though it had worked in the past. I was trying to run a docker-compose file (which works fine when ran in windows btw) but fails on WSL as follows:

Traceback (most recent call last):
  File "/home/myuser/.local/lib/python3.6/site-packages/urllib3/connection.py", line 160, in _new_conn
    (self._dns_host, self.port), self.timeout, **extra_kw
  File "/home/myuser/.local/lib/python3.6/site-packages/urllib3/util/connection.py", line 84, in create_connection
    raise err
  File "/home/myuser/.local/lib/python3.6/site-packages/urllib3/util/connection.py", line 74, in create_connection
    sock.connect(sa)
ConnectionRefusedError: [Errno 111] Connection refused

How do i go about debugging this? I googled and tried netstat and also sudo netstat and I couldn't see anything using up connections.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.