3

I have a brand new FreeDOS Acer Nitro 5 laptop with AN515-55 model name and NH.Q7MEY.001 part number. I encountered an issue during Windows 10 installation on the device. While Western Digital's WDC PC SN530 SDBPNPZ-512G-1014 model 512 GB SSD is visible in BIOS, I cannot see it during installation where to select a disk to install Windows 10 on. From troubleshooting in command prompt through "diskpart utility" if I type in "list disk", again I do not see the 512GB SSD. Only one disk with 3817MB, which is presumably my flash drive that I plugged in, shows up. In my opinion, though unsure of it, if the issue was because of a faulty SSD, then I would not even be able to see the SSD in BIOS in the first place.

I looked through the internet for the issue and came upon similar problems that had been solved by "load driver" option during installation by introducing a proper driver so that Windows 10 setup detects disk mounted on device. Therefore, this led me to incompatibility issue. Windows 10 installation ISO file that I prepared on flash drive through Rufus is earlier version of Windows 10, but the SSD on my laptop is up-to-date. For that reason Windows 10 installation fails to detect the SSD.

With these being said above am I right in such a reasoning?

6
  • Drivers are needed for the controller, not for the SSD. How is it attached, via standard SATA (or mSATA, M.2, etc.)? Can you see a different disc attached to the same controller (or even SATA port, SATA cable)?
    – Albin
    Oct 16, 2020 at 11:20
  • Referring to the SSD's manual I found on the official site it is M.2 2280 S3-M. I do not know how to figure out if another disc is attached to the same controller. Oct 16, 2020 at 11:29
  • Then never mind, did you create the boot medium via the Media Creation Tool?
    – Albin
    Oct 16, 2020 at 11:36
  • What happens if you boot a live OS from a USB Stick? Does it detect the SSD?
    – Albin
    Oct 16, 2020 at 11:40
  • I created the boot medium through Rufus. Now I am recreating a up-to-date Windows 10 ISO file via Media Creation Tool. I will retry with this medium as soon as possible assuming that tool will provide the latest version of Windows 10. Oct 16, 2020 at 12:41

2 Answers 2

3

TO EVERYONE WHO MIGHT HAVE THE SAME PROBLEM: I finally managed to fix this - I had to click CTRL + R anywhere in BIOS and then click CTRL + S on the "Main" tab. When done, SATA settings showed up and I could change that to AHCI. After that, Windows 10 installer finally saw the SSD. Found out the answer thanks to this thread: https://community.acer.com/en/discussion/579607/nitro-5-an515-54-change-sata-mode-from-rst-to-ahci/p1

  • Make sure you use the latest Windows 10 installer (as of today, it is version 20H2, also called 2004 or May 2020 Update). You could use Media Creation tool to download the latest ISO, and Rufus to prepare a bootable flash (as suggested by @Albin above)
  • Try booting from live OS, like Ubuntu, to make sure that everything is OK with the drive
8
  • those are exactly the suggestions from my comments, courtesy dictates to give me a chance to write an answer before "stealing" my ideas to get upvotes...
    – Albin
    Oct 16, 2020 at 14:11
  • Thanks for this article that I have overlooked! I am now trying to install Windows 10 with this setting. I managed to change SATA Mode to AHCI through this method in Acer Community you shared above. I will let you know if that works out. Oct 16, 2020 at 14:17
  • @Albin, I'm really sorry, if it seems so, but in fact I did not try to steal your suggestions - it's just stuff that comes to mind first. As for live OS and drivers, I recommended it yesterday on the previous question for Burak's problem: superuser.com/questions/1594477/…, so I'm just repeating my yesterday's comments as my answer today. The new and key idea of my answer is AHCI mode, which is "novel" to this very question. I've added a reference to your suggestions in the original answer.
    – simon
    Oct 16, 2020 at 19:11
  • 1
    I want to thank you both for help, first of all! Also your response above helped me and I finally installed Windows 10 on my device. The issue is related to SATA Mode, which I have changed from Optane with RAID to AHCI. For that reason your response was on-point to address my issue. Thanks again! @simon Oct 16, 2020 at 20:04
  • 1
    @simon I have no way to verify your statement, and it's very unusual that persons answer question without reading the "full" question thus my rather "strong" statement. Again, it is common curtsey here on the network to give commenter a 1-2 day chance to post an answer after that feel free to do it yourself. Please make sure to check the comments in the future
    – Albin
    Oct 17, 2020 at 8:52
2

On a 2021 ASUS Vivobook 15 F513 laptop with the same "WDC PC SN530" drive there was no option in the UEFI Setup (BIOS) to change the SATA mode from IRST (or Optane with Raid) to AHCI. Furthermore the NVMe SSD is attached to the PCIe bus, not SATA, so I'm not sure that suggestion even applies.

I solved this by following the "load driver" approach. I formatted a USB flash drive as FAT32 (NTFS would probably work just as well), downloaded the Intel® Rapid Storage Technology Driver (IRST) from intel.com, specifically one labeled "floppy driver", and extracted the zip file onto the USB drive. I inserted the drive at the Windows setup drive selection screen (no restart required), and clicked Load Driver, then selected the folder on the USB drive.

I'll note that some comments on the web suggested getting the driver from the manufacturer's site (ASUS in my case), but the Intel driver worked just as well for me. I found the Intel driver by going to their main driver page > Memory and Storage > Which type? > Client SSDs, and picked the driver for 11th Gen, since this laptop has a Core i3 1115G4 (11th Gen).

Not the answer you're looking for? Browse other questions tagged or ask your own question.