0

I have a Sager NP8152-G/Clevo P640RP6-G laptop with Windows 10, with MSHybrid graphics enabled in the BIOS that works with its stock nVidia GeForce 1060 with its latest nVidia drivers: version 456.71 (27.21.14.5671).

It boots into Windows 10 just fine, and works well nearly all the time. It sleeps and wakes from sleep just fine. But, whenever I try to shut down or restart, I get the normal "Shutting down" or "Restarting" with spinner, but then the screen goes blank but the computer keeps running as if it never got the order to actually restart or power down. The computer in this state is totally unresponsive; plugging in a monitor or keyboard doesn't produce any reaction, no keypress helps anything at all. (Thinking maybe Windows was still running, I tried Ctrl+Alt+Del, as well Win+P and the Sleep keyboard keys--no response at all.) I get no beeps and no indication of any activity, other than the fans are running and my power LED is on.

When I change to Discrete graphics in the BIOS (disabling MSHybrid), then the PC will reboot and shut down just fine.

I have the latest BIOS from Sager's site, which are quite old. https://www.sagernotebook.com/drivers.php?cat=645

So any ideas on how to turn on MSHybrid mode and yet still let the computer shut down and restart well?

2
  • Are there BIOS updates and power drive updates available to apply to this laptop?
    – John
    Oct 17, 2020 at 16:18
  • No, not that I can find. I have the latest from Sager's site. Oct 17, 2020 at 16:28

2 Answers 2

0

Have you tested shutdown/restart with disabled fast startup in the energy settings?

https://www.tenforums.com/tutorials/4189-turn-off-fast-startup-windows-10-a.html

Friendly greetings

4
  • Thanks. I do not have that setting: imgur.com/a/KjaCZFH - any other idea? (I already disabled Hibernate, maybe that's why?) Oct 18, 2020 at 0:01
  • If you have deactivated hibernation, this may be the reason that you no longer have the Fast startup option. That sounds stupid, but has the "Memory Integrity" option been activated in the Windows Defender Security Center? Because I once read that someone had problems with the shutdown and after deactivating the problem was solved. If it doesn't, I suspect that the shutdown error is in the area of the Intel Management Engine driver.
    – Tekkie_Boy
    Oct 18, 2020 at 0:26
  • Verified memory integrity is off: (in Start > Settings > Update & Security > Windows Security > Device Security and then under Core isolation, selecting Core isolation details.) Any suggestion of how to troubleshoot the Intel Management Engine? Oct 18, 2020 at 1:29
  • 1
    Fast Startup is a form of hibernation so yes, disabling hibernation will also disable fast startup.
    – Mokubai
    Oct 18, 2020 at 6:22
0

Try this modded bios by Baked on Techinferno. (BUG: If you disable UEFI boot you'll have to force boot through BIOS)

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 14 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.