11

Somehow when I open the terminal on my MacBook Pro 16 (2019) it uses my iPad instead of using my MacBook Pro. I moved from Windows few days ago. I use my iPad at school for writing by my hand and somehow they linked up.

I want to run Flutter from the Terminal but I can’t because is not on the machine I want?

How to switch back to my MacBook Pro?

Here is a screenshot what I see.

enter image description here

  • 7
    FWIW, there should be no way you can use your iPad as a terminal client from the command line like this. So the issue has to be something else. – Giacomo1968 Oct 19 at 12:30
  • 2
    Giacomo1968 Right now I am at home and it shows me in terminal MBP and I don t get it why – Emanuel Pele Oct 19 at 15:19
  • 1
    Wow. Weird. More importantly, is Flutter actually installed on your system? Seems like you were confused by the iPad prompt but even with an incorrect prompt you should be able to launch Flutter. Might be an odd login path issue? – Giacomo1968 Oct 19 at 17:34
  • 2
    There was this very similar issue in the past: superuser.com/questions/663765/… – Tobias Mädel Oct 20 at 9:27
30

More than likely your computer name just changed which is what is displayed in the CLI prompt. These commands via Terminal will shed some light as to the device you're using:

  • Confirm macos version: sw_vers
  • Check who is logged in: whoami
  • Confirm serial number: ioreg -l | grep IOPlatformSerialNumber

If these match your computer info, then change your computer name in “System Preferences -> Sharing.”

There are also additional 'hostnames' which may need to get fixed and can be checked via:

  • scutil --get HostName (or scutil --get ComputerName or scutil --get LocalHostName)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.