1

How do you you remove the Bradford Persistent Agent from a Mac running macOS Catalina?

The main issue is that the given /Library/Application Support/Bradford Networks/Persistent Agent/Uninstall.app application is 32-bit, which my current OS cannot run.

Desired outcomes:

  1. No icon in the system toolbar.
  2. No Bradford-related daemons/tasks launched on start-up.
  3. No more Application Support/Bradford Networks directory.

1 Answer 1

2

All the existing tutorials I could find relied on the Uninstaller program located in /Library/Application Support/Bradford Networks/Persistent Agent/Uninstall.app. Unfortunately, this is a 32-bit app and cannot run on Catalina, which can only run 64-bit (I tried running the executable inside and the error is:

bad CPU type in executable: /Library/Application Support/Bradford Networks/Persistent Agent/Uninstall.app/Contents/MacOS/Uninstall

Within the application contents folder, however, is Resources/Scripts/Uninstall.sh (contents posted below). I cannot verify whether this does everything that the .app container does, but I ran it (sudo ./Uninstall.sh) and it appears that everything was successfully removed: no more launch daemons, no more Bradford Networks directory.

Uninstall.sh

#!/bin/sh
launchctl unload /Library/LaunchDaemons/com.bradfordnetworks.agent.plist 2>/dev/null >/dev/null 
defaults write /Library/Preferences/com.bradfordnetworks.bndaemon.plist expirationTime -string "" 
/Library/Application\ Support/Bradford\ Networks/Persistent\ Agent/LoginItemTiger remove /Library/Application\ Support/Bradford\ Networks/Persistent\ Agent/CSA.app 2>/dev/null >/dev/null
rm /Library/LaunchDaemons/com.bradfordnetworks.* 2>/dev/null >/dev/null
rm /Library/LaunchAgents/com.bradfordnetworks.* 2>/dev/null >/dev/null
rm -r "/Library/Application Support/Bradford Networks" 2>/dev/null >/dev/null
rm -r "/Library/Receipts/Bradford Persistent Agent.pkg" 2>/dev/null >/dev/null
rm -r "/Library/Receipts/Aruba Persistent Agent.pkg" 2>/dev/null >/dev/null
rm -r "/Library/Receipts/bradfordpersistentagentappsupport.pkg" 2>/dev/null >/dev/null
rm -r "/Library/Receipts/bradfordpersistentagentlaunchdaemons.pkg" 2>/dev/null >/dev/null
if [ -x /usr/sbin/pkgutil ]
then
    /usr/sbin/pkgutil --forget com.bradfordnetworks.PersistentAgent
    /usr/sbin/pkgutil --forget com.bradfordnetworks.bradfordPersistentAgent
fi
killall -9 CSA 2>/dev/null >/dev/null
exit 0;
1
  • Nice work dealing with a legacy headache like this! Oct 20, 2020 at 3:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .