2

I want to encode an MKV video to MP4 in HandBrake, but whenever I do this, the resulting video is fine but the audio is horrible - tons of scritchy high pitched artifacts.

How to I tell Handbrake (the GUI version, 1.1.2) to leave the audio track as-is and just add it into the output video without encoding it? Or, failing that, how to have it do a lossless audio encode?

2

Select one of the "Passthru" options as the audio track codec.

enter image description here

Read more here: https://handbrake.fr/docs/en/latest/technical/audio-codecs.html

Passthru options.

HandBrake supports passthru for a limited number of popular source formats. These are: AC3, DTS, DTS-HD, TrueHD, MP3 or AAC (Passthru)

This copies the audio bit-for-bit from the source so offers no loss in audio quality. These audio tracks can be quite large so can impact the final size of the output file quite substantially.

Auto Passthru

In the audio encoders list, there is an option called “Auto Passthru”. When encoding, this will automatically passthru any supported format to the source file. If the source format is not supported, or not supported in the output container, the fallback encoder will be used. The default is AAC.

3
  • 2
    Thanks for fleshing out the answer with images and quotes that explain things. – Giacomo1968 Oct 22 '20 at 18:29
  • This was actually greyed out in the list for me, with the mkv I tried: I only had a couple of audio options like AAC and MP3. – Max Williams Oct 23 '20 at 16:13
  • What is your source audio encoded as? Per the documentation: "HandBrake supports passthru for a limited number of popular source formats." – wysiwyg Oct 23 '20 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.