1

My PC is having issues connecting through my USB Wi-Fi network adapter to 2.4GHz Wi-Fi, but it has no issues with connecting to 5GHz.

I looked for an answer for this issue online and tried a few suggested steps, but to no avail. Troubleshooting didn't work.

How can I make it connect on 2.4GHz?

(USB Wi-Fi network adapter: Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter)

  • 1
    Sorry, but this site is a question and answer site. If you found a solution, and wish to share it, you should post the question as a question and then post your solution as an answer. Also, please do not declare “SOLVED” in a title. A solution on this site is a checked off answer. Self-answering questions is fine. – Giacomo1968 Oct 23 at 19:34
  • I submitted an edit to your question to make it appropriate for the site's format. I also provided an answer that is based on yours, but expands for people with more modern WiFi NICs as well. Please accept the edit and you can either accept my answer or write your own if you feel you have a better answer than the one I provided. – Hashgrammer Oct 23 at 19:48
1

Try locating your WiFi network adapter in Device Manager. Select it and hit "Properties", then go to "Advanced". Choose "Wireless Mode" and change it from "Auto" to "IEEE 802.11b/g/n" (or if you have 2 Wireless Mode Settings, set the a/b/g to "Dual Band 802.11a/b/g" and the n/ac/ax to 802.11n) and hit Apply, then OK.

enter image description hereenter image description here

See if you're able to connect after that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.