0

I tried to unpack an ISO of Ubuntu to USB stick without writing it (i can't use superuser utilities like dd or Rufus). Then i set my USB stick first in UEFI boot priority. I got working GRUB, but when i tried to run the system in live i got this error:

Initramfs unpacking failed: Decoding failed;
Unable to find a medium container a live file system
Attempt interactive netboot from a URL?

Maybe there is a way to run it from grub shell?

2
  • To create a bootable USB, you need to create a boot partition, which is what Rufus, UNetbootin and other utilities do. See alternativeto.net/software/unetbootin for alternatives, but you'll need to run as sudo to install. If you have access to a Windows machine, you can create a USB there with Rufus. Oct 25 '20 at 17:58
  • @DrMoishePippik but it seems to run .efi files fine even without boot partition on USB stick.
    – DenisNovac
    Oct 26 '20 at 4:15
0

After some tries i found out i can repack Arch (it was archlinux-2020.10.01-x86_64 image) and some UEFIs will be able to run it's grub. The Arch itself won't run but it will startup an emergency shell (which seems to not be a thing in Ubuntu). This shell have mount and dd utilities, so it is possible to create a bootable device afterwards. And you don't need superuser rights to just repack an ISO to USB stick (in fact, it was done with SD-card on non-root Android smartphone). It worked on 2 out of 3 laptops i tried.

So i repacked an arch.iso into SD-card and also placed ubuntu.iso into it. In Arch's emergency shell i wrote ubuntu.iso into the USB stick by dd. And then i was finally able to run it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.