20

I have received warning popup box "You are currently using the RemoteFX 3D Video Adapter. We no longer support this adapter ..." after I installed new graphic card.

I tried to open link provided in this message: https://support.microsoft.com/en-us/help/4570006/update-to-disable-and-remove-the-remotefx-vgpu-component

But it seems it describes a Windows update which supposed to disable this feature. Not how to disable it by hand.

Googling yielded two results - Remove-VMRemoteFx3dVideoAdapter - which is not applicable in my case - I have Hyper-V running on my machine but I have no VMs. And this command works with VMs.

Another one - Disable-VMRemoteFXPhysicalVideoAdapter - it requires name. So I ran get first:

PS C:\Windows\system32> Get-VMRemoteFXPhysicalVideoAdapter
WARNING: We no longer support the RemoteFX 3D video adapter. If you are still using this adapter, you may become
vulnerable to security risks. Learn more (https://go.microsoft.com/fwlink/?linkid=2131976)


Id                          : pci#ven_10de&dev_1d01&subsys_375d1458&rev_a1#4&2ae1b128&0&0019
Name                        : NVIDIA GeForce GT 1030
GPUID                       : 4318_7425_928846936_161
TotalVideoMemory            : 36392450048
AvailableVideoMemory        : 36392450048
DedicatedSystemMemory       : 0
DedicatedVideoMemory        : 2078662656
SharedSystemMemory          : 34313787392
Enabled                     : False
CompatibleForVirtualization : True
DirectXVersion              : 12.1
PixelShaderVersion          : 5.0
DriverProvider              : NVIDIA
DriverDate                  : 2019-07-24 02:00:00Z
DriverInstalledDate         : 2019-07-24 02:00:00Z
DriverVersion               : 26.21.14.3200
DriverModelVersion          : 2.6
CimSession                  : CimSession: .
ComputerName                : xxxxx
IsDeleted                   : False

then:

PS C:\Windows\system32> Disable-VMRemoteFXPhysicalVideoAdapter -Name "NVIDIA GeForce GT 1030"
WARNING: We no longer support the RemoteFX 3D video adapter. If you are still using this adapter, you may become
vulnerable to security risks. Learn more (https://go.microsoft.com/fwlink/?linkid=2131976)

My OS is W10 v 2004 build 19041.572 and Windows Update shows that everything is up to date..

How do I make sure this "RemoteFX 3D" is securely disabled?

1
  • 2
    Getting the same popup...
    – serilain
    Oct 27, 2020 at 0:11

3 Answers 3

18

I also kept receiving that popup. I do not have any VM running but I do have WSL2 running, which it does on top of Hyper-V (plus Docker using WSL2, I do not know if this plays a role in it).

Here is what I did :

  1. Get the name of the video card. Here I could see that the driver was enabled.
Get-VMRemoteFXPhysicalVideoAdapter

enter image description here

  1. Disable RemoteFX adapter. Obviously, provide it with the name of your own card.
Disable-VMRemoteFXPhysicalVideoAdapter -Name "NVIDIA Geforce GTX 970"

Now I cannot really check if this worked because the popup only appears very not-often, but it does show disabled :

enter image description here

5
  • 1
    It's possibly better to disable with the -Id flag instead, since two adapters can have the same name, but not the same Id?
    – zylstra
    Dec 26, 2020 at 0:15
  • 1
    What exactly will it disable? I feel like disabling a display output might be a bad Idea, if I don't understand what will turn dark afterwards. Thanks! Jan 24, 2021 at 14:48
  • @zylstra There is no -Id flag
    – Mickael V.
    Feb 28, 2021 at 14:00
  • 1
    @ZsoltSzilagy It will disable the ability for VMs to use your GPU, through the vGPU with RemoteFX. You can check this KB for alernatives : support.microsoft.com/help/4570006
    – Mickael V.
    Feb 28, 2021 at 14:03
  • @MickaelV.I could have sworn -Id is what I used. Whatever the case then, I see that I cannot use it now. And the great thing about -Name is that it (now) disables ALL adapters with that name, so you only have to enter the command once.
    – zylstra
    Mar 1, 2021 at 20:03
13

After reading @Mickael's answer, this worked for me (at an Admin Powershell prompt):

Get-VMRemoteFXPhysicalVideoAdapter | ?{$_.Enabled} | Disable-VMRemoteFXPhysicalVideoAdapter
1
  • 1
    Nice all-in-one solution. Thanks! :) --- Makes you wonder why, if this is suitable, MS don't just push this as part of the update that provided the annoying pop-up!
    – Jack_Hu
    Feb 27, 2021 at 16:10
1

I just had my first experience with this: the Microsoft link has a tidbit - it seems MS will eventually remove the adapter from Windows in March 2021, and it seems disabling is the best we can do for now. But I am still looking for a manual deletion method.

https://support.microsoft.com/en-us/topic/update-to-disable-and-remove-the-remotefx-vgpu-component-in-windows-bbdf1531-7188-2bf4-0de6-641de79f09d2

Removal: RemoteFX vGPU will be removed from all applicable Windows platforms in the March 2021 Windows security updates (March 9, 2021)

In the mean time, I found this one liner in PS appears to disable the feature:

Get-VMRemoteFXPhysicalVideoAdapter | Disable-VMRemoteFXPhysicalVideoAdapter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.