As you have probably noticed my last questions are all about Ubuntu, because I had migrated several weeks ago from Windows 7. And I think it is usual thing that until I get used to Ubuntu I will have a lot of problems.
So, I have Dell Vostro 1710 laptop. SOMETIMES its touch pad doesn't work completely, i.e. cursor doesn't move and it doesn't react to my movements in touch pad. In this case I use my lovely Logitech laser mouse. As it is wireless mouse it has USB receiver and it is always connected to my laptop (because it is really very small and it is like "Connect and forget"), that is why I never disconnect it.
I have never had any problem with my Touch pad in Windows. My wireless mouse had been connected always too.
Question: What is wrong here in my Ubuntu that my touch pad doesn't want to work sometimes? It is so strange that it happens occasionally, but still it is kind of annoying thing for me.
Thank you.


UbuntuForums thread: Vostro 1710 hardware issues

problem description from there,

Everything works apart from when my keyboard and touchpad randomly don't...
I have no idea why it happens but it's not very often.

solution from there,

fixed the touchpad/keyboard bug.
You need to add i8042.reset to the end of the kernel boot line in

PS: You may want to add your experiences with the Dell Vostro 1710 to Ubuntu Laptop Testing Reports.

  • But there is no such a file called menu.lst in my /boot/grub/ folder. – Bakhtiyor Jul 4 '10 at 20:16
  • In Ubuntu 10.04 and higher you need to add i8042.reset command in /etc/default/grub instead. Find GRUB_CMDLINE_LINUX_DEFAULT in this file and add i8042.reset to it. Final result will look like this: GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash" – Bakhtiyor Jul 21 '10 at 7:29

I had issue with my Elan touchpad and my solution after a bunch of head ache was to shut down computer, unplug, and pull the battery out. After doing so I touched the touchpad while computer is off and the power button. Then put battery back in and started up and it was solved... Magic! It worked for my problem (Touchpad was not even showing up in device manager computer didn't think it had one, it wouldn't even work when I booted into Linux) There must of been some really weird charge on the capacitor so this allowed it to discharge. Think of it as hitting the reset button.

And of course make sure your touchpad is enabled in the bios or with the touchpad on/off button either on your keyboard F-Keys or a button next to the touchpad (that the touchpad off button is not set). Also check touchpad settings in your mouse settings section to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.