0

enter image description hereI have Windows 7 with .net framework 3.5, and unfortunately , Razer synapse 2.0 needed the net framework 4.0 so I tried to install the following versions of Net framworks-

4, 4.5.1, 4.5.2, and more versions higher than 4.0

All of these failed to install giving no error code.And in the control panel when I chek the Windows features, it gave me the latest version of .net framework to be version 3.5 . So IF net framework does not install , what can I do to run Razer Synapse, because Synapse seems to a bloated program and without it I am not able to configure out my mouse .

6
  • 1
    I can confirm that the program in question works without issue if you have .NET Framework 4.0+ installed. So what version(s) do you currently have installed? Instead of replying with a comment you should edit your question. Please provide a screenshot of the installed versions from with Control Panel and/or Windows Features.
    – Ramhound
    Oct 29, 2020 at 13:38
  • I know the versions and in the control panel it shows me that the latest one is .net framework 3.5 Oct 29, 2020 at 13:40
  • It would be very strange if you didn’t have some version of .NET Framework 4.0+ installed already. Please provide the information I have asked for. It’s not possible to run a .NET Framework 4.0+ application if you only have .NET Framework 3.5 installed. If you don’t have 4.0+ installed then you would need to install .NET 4.8 (the current version) in order for the application to run.
    – Ramhound
    Oct 29, 2020 at 13:45
  • I said that the latest one is .net 3.5 I will send the screenshot shortly Oct 29, 2020 at 13:46
  • An installation log was generated when you attempted to install those .NET Framework 4.0+ You will need to provide that log
    – Ramhound
    Oct 29, 2020 at 13:54

1 Answer 1

1

So IF net framework does not install, what can I do to run Razer Synapse, because Synapse seems to a bloated program and without it I am not able to configure out my mouse.

It is not possible to run the application in question, without installing .NET Framework 4.0 or higher, so you will have to diagnose the reason your unable to install a compatible version.

The application in question cannot be ran if you only have .NET Framework 3.5 installed.

3
  • Start a New question for diagnosing 4.5 install failure.
    – Moab
    Oct 29, 2020 at 15:04
  • But where to find the installation log , which would be neccessary to make the installation diagnosing? Oct 30, 2020 at 3:40
  • I will post an new question regarding this for sure, after I find that installation log Oct 30, 2020 at 3:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .