I tried to install fedora 33 on an external SSD.

What I did:

download fedora image and write it to an usb stick with:

sudo dd if=Downloads/Fedora-Workstation-Live-x86_64-33-1.2.iso of=/dev/sde bs=8M status=progress oflag=direct

works as expected. The stick boots fine and it looks like it worked in UEFI mode, but I am not sure.

I selected the external SSD as disk to install, everything to delete on that disk, Installation run without error. But after reboot and removing the usb stick, the SSD is not booted.

I have no idea what I can check in such a stupied simple case. Is there any chance to force the installer to install a normal mbr without uefi if uefi is the problem here?

I also created the usb stick with

sudo livecd-iso-to-disk --format --reset-mbr Downloads/Fedora-Workstation-Live-x86_64-33-1.2.iso /dev/sde

but this stick was not bootable at all... Great!

  • Are you sure you can boot from SSD? Some older PC's do not recognize an SSD as a bootable device, and you did not mention your PC. Commented Oct 30, 2020 at 18:20
  • @DrMoishePippik Definitely yes! I simply copied the ISO image of the installer to that disk and it boots in the same way as the installation usb stick. ( I used the same dd command as above to the new SSD device and it works perfect for booting ) But as mentioned, if I install from usb stick to that SSD, it did not boot.
    – Klaus
    Commented Oct 30, 2020 at 18:22

1 Answer 1


Looks like you've chosen the wrong media. To write Fedora 33 onto the SSD directly, you'll need the raw image (use dd or pv to write to SSD / MMC).

It's on its own page (alternative architecture), Fedora 33 also has an IoT spin.


For example, I chose the minimal to start with (preferred), Fedora Minimal, file name -> Fedora-Minimal-33-1.3.aarch64.raw.xz.

You'll need to decompress to get the .raw image file and then use your preferred to tool to write, e.g. pv <Fedora-Minimal-33-1.3.aarch64.raw >/dev/<blk>.

NOTE: of course you can use xzcat and | as one-liner.

Download | use the Fedora 33 aarch64 raw image instead of the ISO (ISO is from install like x86_64).

Pi 4 can boot directly from USB (officially) since September 2020. See this post, before that I had to manipulate the EEPROM dump to change boot order and and update the EEPROM for that to work (have been running Manjaro ARM aarch64 with KDE Plasma since end of June) on a cheap 850 EVO SATA SSD (make sure the USB to PCIe or USB to SATA chip supports UASP + TRIM).

NOTE: JMS583 RTL9210 (USB to PCIe for NVMe M.2 SSDs), VL716 (USB to SATA).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .