3

I'm using Handbrake to rip old DVDs to .mp4 video, and the result I am getting is a video file that skips every second or so and repeats a previous section of the audio and video. Incidentally I got a similar result from the same DVD when I saved the .vob files to a hard drive using an old version of Mac The Ripper and played the .vob files. When I play from the DVD directly on the same computer using the built in Apple DVD Player application, it does not skip. How can I address this to save the video file to some sort of modern video format that Google Photos supports without skipping?

Example of the video file saved.

Details: Handbrake Version 1.3.3 (2020061300) Mac OS 10.14.6 I used the generic preset in Handbrake of "Fast 1080p30" without changing any of the settings. enter image description here Also got the same result when using a different preset in Handbrake: "Vimeo YouTube HQ 1080p60".

4
  • Might be a DVD drive issue. I mean, if you can play it on a DVD player but this happens on your computer that is the only idea I can come up with. One idea to do an end-run around this is to hook up your DVD player via a video capture device and just record it into the PC that way. – Giacomo1968 Nov 1 '20 at 20:44
  • 1
    Try ripping the DVD using MakeMKV first. Last I knew Handbrake did not support DVD decryption so it may be having trouble. – Mokubai Nov 1 '20 at 22:04
  • I just edited the post to clarify that I did the DVD playback on the same computer, not a standalone DVD player. – Mike Eng Nov 2 '20 at 3:05
  • 1
    Have you tried with multiple DVDs? Might be an issue with one particular DVD - perhaps some kind of copy protection? – Ashley Nov 2 '20 at 10:24
2

Try using VLC player to convert the video - There are plenty of guides online, like the one here https://www.laptopmag.com/uk/articles/convert-video-using-vlc

If still not good quality, or the same as before, create a new login user, make sure it is an admin, login, then attempt either handbrake or vlc to convert.

If this still doesn't work, it's a performance/ram/codec issue - which is a little more difficult to solve.

1

Did you play the DVD in the computer or in a separate DVD player?

  • If using another player then the issue may with the PC's player or drivers.
    • Clean the optics cautiously with a CVD/DVD cleaner disc.
    • Check that DVD drivers are updated.
    • Check media regional settings. Commercial disks may be locked to a specific region.
  • If in the PC, what player are you using? Some players, such as VLC, can stream a video file directly to your HDD in other format, or can stream the video output to disk. This is slower and less efficient than ripping a disk directly, though.
2
  • Thanks. All of the playback was done on the same computer (not a separate DVD player). To play the saved video files, I used Quicktime Player for the .mp4 and VLC for the .vob. I played from the DVD directly using the built in Apple DVD Player. – Mike Eng Nov 2 '20 at 3:02
  • Then, since you know VLC works, and it can play both MP$ and VOB (as well as many other formats), you can, at worst, stream the output to file. – DrMoishe Pippik Nov 2 '20 at 3:55
1

I realize this is a really unsatisfying answer, but I tried again with the same setup using Handbrake and the same DVD that was causing the problem earlier, and it converted the video file without any video or audio skipping. My best guess is that it was a performance issue as @JohnnyVegas suggested in their answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.