9

I am confused why this simple right() function doesn't work in my Excel 2010.

Column A is formatted as Text, Column B is formatted as General. There are no extra spaces or unusual characters in Cell A1.

I don't get an error if I do NOT specify the second argument (number characters) otherwise I do get the error instead of the expected result: "le". enter image description here

Even when the cursor is placed alongside the 2 in the right() function second argument field Excel doesn't make bold the num_chars argument underneath. It's like Excel doesn't accept the second argument I have provided? enter image description here

3
  • 6
    It looks a lot like your parameter delimiter has been changed to | rather than , – Mokubai Nov 2 '20 at 12:23
  • 3
    Seems to be some info here and here apparently it is probably your "list separator" setting in your system language settings. – Mokubai Nov 2 '20 at 12:28
  • Thank you very much. That's exactly what it was. If you want to make an answer I will accept it. – FlexMcMurphy Nov 2 '20 at 12:30
26

It looks like your function list separator has changed and rather than , you will need to use |.

enter image description here

It may be that your "list separator" setting in your system language settings has been changed or is dependent on your language. For English , is common, but in other languages ; is used instead. On Windows 10 2004 you can get to the settings by SettingsTime & LanguageRegionAdditional date, time & regional settings (opens old control panel) → Change date, time or number formats (aka Region) then under Additional Settings you should be able to change the following.

enter image description here

This will be system wide, so be sure you want to do this. If other people use this machine they may find it odd or confusing for it to have changed.

More information can be found at Force Excel to use commas (,) instead of semicolons (;) in separating formulas

1
  • Regional settings are not system-wide for existing users, although it's possible that this procedure may change the default settings for new users. – Neil Nov 3 '20 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.