1

Recently, Visual Studio 2019 is performing very slowly in auto-completion, showing suggestions, detecting errors, expanding and collapsing. What could be the reason for this? and how can I fix this?

2
  • 1
    Try to start Visual Studio in safe mode via devenv /safemode. If this is fast enough, then the problem is with some installed extension. – harrymc Nov 4 '20 at 20:59
  • @harrymc It worked faster, but without most of functions of course, like auto-completion, but detecting errors, expanding and collapsing are fast. What should I do now? – AbdelAziz AbdelLatef Nov 4 '20 at 21:14
1

The slow-down was fixed by starting Visual Studio in safe mode, via devenv /safemode. This means that some installed extension has become troublesome and needs to be uninstalled. You will need to find it by trial and error.

To uninstall an extension that was installed by a standard .vsix installer:
Run menu Extensions > Manage Extensions, click on "Installed" and then on the extension. You will see two buttons: "Disable" and "Uninstall". Try "Disable" first and restart Visual Studio. If the problem is fixed, then use "Uninstall" on the bad extension. For good extensions, the "Disable" button will be replaced by "Enable" and they can be returned.

For extensions that use other installers like .msi, they can typically be uninstalled from Control Panel > Programs and Features. They can only be uninstalled, not disabled.

2
  • I removed one duplicated extension, had two versions, and it improved somewhat, I will keep looking for other problems. Thank you. – AbdelAziz AbdelLatef Nov 5 '20 at 0:31
  • It seems the main problem was in CUDA 11.1, but I have to use it. – AbdelAziz AbdelLatef Nov 6 '20 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.