0

I am new to ffmpeg to I'm sorry in advance for my lack of knowledge. All I'm trying to achieve is to mux a video (mp4) and audio (wav) file together to create an mov, which I thought should be simple enough.

I had never used ffmpeg before but tried following tutorials online to achieve this. I downloaded the program from one of the links provided by the official website (https://ffmpeg.org/download.html#build-windows). The build I downloaded had this file name: https://www.gyan.dev/ffmpeg/builds/ffmpeg-git-full.7z

Inside the folder there were these contents

I extracted the folder and placed all contents in a new folder named "ffmpeg" I created in C:\

Then I went to advanced system preferences, into environment preferences, path, and added C:\ffmpeg\bin

(All these instructions I got online).

I then opened the command prompt, running it as an administrator to input my ffmpeg command. I first verified that ffmpeg was running smoothly by using the command ffmpeg -version (which worked).

Then I added my mp4 and wav files to the same bin folder as ffmpeg and tried all of these commands:

ffmpeg -i video.mp4 -i AMBIX.wav -c:v copy -c:a aac output.mp4

ffmpeg -i video.mp4 -i AMBIX.wav -map 0:v -map 1:a -c:v copy -c:a copy youroutput.mov

ffmpeg -i "video.mov" -i "AMBIX.wav" -map 0:v -map 1:a -c:v copy -c:a copy "youroutput.mov"

ffmpeg -i video.mp4 -i AMBIX.wav^ -c copy youroutput.mov

ffmpeg -i "30-10 ECHOES VR EXPORT 2".mp4 -codec copy -an "OUTPUT.mp4"

ffmpeg -i video.mp4 -i AMBIX.wav -shortest -c:v copy -c:a aac -b:a 256k OUTPUT.mp4

As you can see, I also tried mov files and I tried substituting audio in a file instead of muxing. None of these commands worked and I got the same error every time (for any of the video files): No such file or directory

whyyyy it does exist ffmpeg!

I'm legit so frustrated. I tried this on three different computers too, but I am obviously doing something wrong. I tried multiple files since maybe one was corrupted??

I just want my wav file to be with this mp4 because it's an ambisonics file and premiere kills ambisonics when muxing tbh.

If anyone could help me out or even suggest another way to properly mux an mp4 and a wav file with spatial sound I will legit cry of joy.

Thanks in advance!

1 Answer 1

1

You are in working in C:\WINDOWS\system32. Your video files probably are not in that folder.

You have to use dir to navigate to the folder that has your video files.

Or an easier method:

  1. Open Windows Explorer.
  2. Go to the folder that has your videos.
  3. Hold down Shift.
  4. Right click in Explorer in a blank area of the folder.
  5. Choose "Open command window here" or "Open PowerShell window here".
  6. Now run your ffmpeg command.
2
  • Dude..... How was it that easy?! Nov 5, 2020 at 22:56
  • Thank you soooooooo much!!! I spent 10 hours trying to fix this and you solved my problem in 6 steps lol Nov 5, 2020 at 22:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .