2

I am currently learning about network engineering and was in the middle of monitoring my ARP cache when I realised I could ping my Windows 10 laptop (192.168.0.12) from my Windows 10 desktop (192.168.0.15) but not vice versa.

I read that this may have something to do with my firewall settings, so I took a look under the Inbound and Outbound Core Networking rules and found that on both machines I had the the same settings...

Inbound

Core Networking Diagnostics - ICMP Echo Request (ICMPv4-In): Private, Public, Enabled - no
Core Networking Diagnostics - ICMP Echo Request (ICMPv4-In): Domain, Enabled - no
Core Networking Diagnostics - ICMP Echo Request (ICMPv6-In): Private, Public, Enabled - no
Core Networking Diagnostics - ICMP Echo Request (ICMPv6-In): Domain, Enabled - no

Outbound

Core Networking Diagnostics - ICMP Echo Request (ICMPv4-Out): Private, Public, Enabled - no
Core Networking Diagnostics - ICMP Echo Request (ICMPv4-Out): Domain, Enabled - no
Core Networking Diagnostics - ICMP Echo Request (ICMPv6-Out): Private, Public, Enabled - no
Core Networking Diagnostics - ICMP Echo Request (ICMPv6-Out): Domain, Enabled - no

...so when I set the Inbound Public, Private IPv4 rule on the desktop to...

Core Networking Diagnostics - ICMP Echo Request (ICMPv4-In): Private, Public, Enabled - yes

...I was now able to ping both ways just fine.

I am just trying to understand why I was able to ping from laptop -> desktop with the default firewall settings, but in order to ping from desktop -> laptop I had to change them. Thanks for any insights into this

  • 2
    Are network connections on both computers marked as private? – gronostaj Nov 6 '20 at 13:56
  • 1
    OK closing because network discovery was not turned on on the desktop PC. Can't believe I didn't check that, thanks for the pointer – PumpkinBreath Nov 6 '20 at 14:13
  • 2
    Please don't just add 'solved' to the question title. If you want, you can answer your own question, then also accept it. Whilst it has no answer, you could also choose to delete it, if you think it to be of no value to future users. Once there's an answer you can't do that. – Tetsujin Nov 6 '20 at 14:27
1

This was an oversight on my part.

If you have experienced this problem yourself then try going to:

Control Panel -> 
Network and Sharing Center -> 
Change advanced sharing settings

From there select Turn on network discovery for your home network connection. This solved the problem for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.