1

Setup

SSD 1: Windows 10

SSD 2:

  • Partition A: Elementary OS (EOS)
  • Partition B: "DATA", formated as exFAT

Problem

I use DATA for some work related stuff under EOS. Worked like a charm. Logged into Windows, accessed DATA from there. Now I have an issue under EOS: via file-explorer I can mount DATA and see the stored folders, but all folders are displayed empty. The volume shows the free storage correctly. When using bash, DATA is mounted under /media/joba2ca/DATA and I can access the folders. But when I ls in /media/joba2ca/DATA/workfolder, I get an error that "folder '.' is currently being accessed: I/O error" (translated from German). There is another non-work folder on DATA, /media/joba2ca/DATA/nonworkfolder, that I can access without any issues. I would like to access the work-related data again.

Troubleshooting so far

Seems to be related to Windows 10 hibernation stuff and not properly unmounting. Therefore I...

  • "unshared" one of the folders under Windows 10 that I previously shared while troubleshooting (don't judge me)
  • changed W10 energy options to disable fastboot and hibernation
  • unmounted drive via (a) disk management tool (b) command line with mountvol D: /P (D: was mountpoint of DATA)
2
  • Have you installed in EOS the packages exfat-fuse and exfat-utils? – harrymc Nov 11 '20 at 15:35
  • Thanks for your reply! Yes, I have them installed. – joba2ca Nov 11 '20 at 15:37
0

Found an unexpected, because simple, solution:

  1. Under Windows 10, access /media/joba2ca/DATA/workfolder
  2. Move all contents into /media/joba2ca/DATA/
  3. rd /workfolder. Does not work, because "folder is corrupted" and because Windows
  4. Log into Elementary OS
  5. rm -r /workfolder
  6. Solved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.