0

I'm experiencing a bizarre issue with the taskbar notification area in Windows 10 1909. I only just noticed this issue but I have no idea how long it's been happening since I didn't pay too much attention to the notification area before.

If I only enable a single icon in the notification area then everything is fine, the one icon is displayed in the notification area. But if I enable two or more icons, then all the icons are displayed except for the first one, which is replaced by an empty space.

Here's what it looks like:

enter image description here

I actually have three icons enabled, but there's an empty space where the first one should be, between the two icons and the input method selector (the ENG DV thing).

I experience this issue regardless of which icons I choose; as long as I've enabled more than one, the first one I enable is hidden, while the others are correctly displayed. The same is true even if I put the taskbar on the right or left side of the screen, so that it's verti

I have tried deleting the "IconStreams" and "PasticonsStream" keys in \HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify, which I've seen suggested in a number of places, but this had no effect.

I haven't been able to find any mention of this issue on the internet, let alone a solution, so I'd greatly appreciate any help here.

EDIT: another thing I noticed, in case it helps diagnose the problem: if, when dragging a new icon onto the notification area, my mouse cursor is on the blank space when I let go of the mouse button, I see this weird UI element in the space where the first icon should be:

enter image description here

As soon as the mouse leaves that space it goes away and goes back to being an empty space.

13
  • Try making your clock just the small clock. Then it fits on one small line and I think your space in the system tray will normalize. I think the large (expanded) clock format is doing this.
    – John
    Nov 12 '20 at 2:17
  • @John Hmm so I couldn't find a way to make the clock smaller other than enabling "Use small taskbar settings" in Taskbar settings, but that didn't help. I also tried disabling the clock altogether (as well as the input indicator) but that didn't help either.
    – yuji
    Nov 12 '20 at 2:29
  • Try this article thewindowsclub.com/display-seconds-in-taskbar-clock-windows
    – John
    Nov 12 '20 at 2:36
  • If you don't mind the change in appearance, increase the Taskbar height to two or three full rows. Nov 12 '20 at 2:55
  • @John I tried the registry tweak in that article and it didn't do anything (i.e., it didn't even show seconds in the clock). Also the article itself can't even seem to make up its mind about what it wants to suggest...
    – yuji
    Nov 12 '20 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.