0

I've installed steam-1.0.0.66-1.el8.i686.rpm on CentOS 8.2 and I am using the latest nvidia driver with cuda 455.32.00 and I get this:

[2020-11-12 02:59:20] Startup - updater built Oct 28 2020 23:34:22
Installing breakpad exception handler for appid(steam)/version(1603992987)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  GLXBadContext
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  150 (GLX)
Minor opcode of failed request:  3 (X_GLXCreateContext)
Value in failed request:  0x0
Serial number of failed request:  45
xerror_handler: X failed, continuing
Major opcode of failed request:  150 (GLX)
Minor opcode of failed request:  6 (X_GLXIsDirect)
Serial number of failed request:  46
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2020-11-12 02:59:21] Failed to load cached hosts file (File 'update_hosts_cached.vdf' not found), using defaults
[2020-11-12 02:59:21] Using the following download hosts for Public, Realm steamglobal
[2020-11-12 02:59:21] 1. http://client-download.steampowered.com, /client/, Realm 'steamglobal', weight was 100, source = 'baked in'
[2020-11-12 02:59:21] 2. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1603992987)
[2020-11-12 02:59:21] Checking for update on startup
[2020-11-12 02:59:21] Checking for available updates...
[2020-11-12 02:59:21] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
Installing breakpad exception handler for appid(steam)/version(1603992987)
[2020-11-12 02:59:22] Download skipped: /client/steam_client_ubuntu12 version 1603992987, installed version 1603992987, downloaded version 0
[2020-11-12 02:59:22] Nothing to do
[2020-11-12 02:59:22] Verifying installation...
[2020-11-12 02:59:22] Performing checksum verification of executable files
[2020-11-12 02:59:23] Verification complete
Loaded SDL version 2.0.13-6142881

(steam:4739): Gtk-WARNING **: 02:59:23.200: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier 'direction', expected character '}'

(steam:4739): Gtk-WARNING **: 02:59:23.203: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant
Gtk-Message: 02:59:23.203: Failed to load module "pk-gtk-module"
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Steam: An X Error occurred
X Error of failed request:  GLXBadContext
Major opcode of failed request:  150
Serial number of failed request:  49
xerror_handler: X failed, continuing
Steam: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  150
Value in failed request:  0x0
Serial number of failed request:  48
xerror_handler: X failed, continuing
Steam: An X Error occurred
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  150
Serial number of failed request:  50
xerror_handler: X failed, continuing
assert_20201112025920_1.dmp[4810]: Uploading dump (out-of-process)
/tmp/dumps/assert_20201112025920_1.dmp

What I am missing?

5
  • I think, that installation something from gtk2 will solve the problem, but to old version of steam. Nov 12, 2020 at 7:09
  • I reinstalled drivers, nothing change. Nov 12, 2020 at 16:14
  • Okay, check out this post as it seems Centos 8.2 github.com/ValveSoftware/steam-for-linux/issues/7449 related specifically and current 2020-11 so this might be the fix you need. Check it out and update me on the exact fix applied if it resolves. Nov 12, 2020 at 16:22
  • I check it but I have installed newer version driver i. e. 455.32.00 from cuda repo and in your link they are using 450.80.02. Nov 12, 2020 at 21:49
  • Maybe try a version of the driver that's one version back older and keep moving back a version and maybe something will work version wise that's older in your configuration. Maybe it's related to something that's x86 versus x64 or vice versa. I really don't know much about this sort of configuration you have but figured I'd take a stab at some googling for you on those areas. I know how to use Information and Technology so thought I'd give you an IT pointer or two. Not sure in this case otherwise but I have a feeling it's related to a buggy driver, CPU mismatch, or something like that. Nov 12, 2020 at 23:34

0

You must log in to answer this question.

Browse other questions tagged .