1

I'm just testing Linux Live Kit to see how to get it to work. I'm doing this while running a Linux Mint 20 with Cinnamon ISO in live mode while in VirtualBox, which is also running on Linux Mint 20. According to the following link, it's fine to run it in a VM:

https://helpdeskgeek.com/linux-tips/make-a-custom-live-linux-distro-with-linux-live-kit/

All I've done to the system is booted it in live mode and made a text document on the desktop, just to test if it puts it into the new ISO. So to try to get it to work, I've installed what it said to install:

sudo apt-get update && sudo apt-get install squashfs-tools

And I downloaded the package from the GitHub link that it provided and also installed a couple things that the documentation said that I might need:

sudo apt-get install genisoimage might possibly be necessary sudo apt-get install mkisofs might possibly be necessary

None of this caused any errors. My linux-live-master folder is placed inside /tmp, so I had to go inside that sub-directory to get to the build file (slightly contrary to the instructions, but whatever). Then I ran this:

sudo ./build

It started fine and said:

Changing curent directory to /tmp/linux-live-master Building intramfs image...

But then immediately after that it said:

cp: cannot stat '/vmlinuz': No such file or directory

And then it stopped. I saw in some of the included documentation that the config file must point to the vmlinuz file and have it inside the boot directory, so I went into the config file and changed this line:

changed VMLINUZ=/vmlinuz

to

changed VMLINUZ=/boot/vmlinuz

I looked in that directory to verify that the file is there, and it is (though it seems to be an alias/symbolic link/shortcut/whatever - I'm a bit new to Linux, so I may not have all of the terminology just right).

Then I tried running the build file again and it did the same thing as before, but changed the final line to:

cp: cannot stat '/boot/vmlinuz': No such file or directory

So what am I doing wrong? I'd really appreciate some help. And keep in mind that ultimately I'm going to be doing this from distributions of Linux already installed onto USB sticks, which I want to turn into new live ISO files, but I thought I'd start with a VM just for convenience.

Also, I'd really like to make sure that when it creates the new live ISO, it will allow a secure login (which for some reason I've had trouble establishing when using a live ISO with persistence enabled by Ventoy, so I don't know how well it would work with this), and also I'd like to remove the installer program (I think it's called Ubiquity, but I'll be using other distribution in addition to Mint), because ultimately I don't want it to be able to be installed onto a hard drive, but rather I just want it to always run in live mode. Thanks a lot if you can help me.

1

I had to use the same tool today and got the same error. To fix it you need to get the whole file location. To see what is the correct one if you want to make the live with running kernel version run this command: uname -r and it'll give you the version of the kernel you are running on.

Then change the vmlinuz on the config file to vmlinuz-xx where xx is the output of the command above.

Then run the build script and it should work fine.

1

You have to know the exact location and name of your vmlinuz file. In my case (I am using Garuda Linux), the file is vmlinuz-linux-zen and is located at /boot. So, I've changed the config file with VMLINUZ=/boot/vmlinuz-linux-zen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.