I just upgraded to Windows 7, and now I'm having trouble working with some files that were on an external drive. Naturally, the user that created them doesn't exist anymore. On some files, the administrators group in Windows 7 was automatically granted full control, but for some reason not on others.

In particular, I'm trying to delete a bunch of files. So, I first set the owner of the parent folder to me, and checked the box to apply recursively to subfolders. Then I tried setting the owner to the Administrators group. I tried adding full permissions to "Everybody" and propagating the change to all subfolders. None of this works - the propagation doesn't work. Depending on exactly what I try next, I'm sometimes being told that I need permission from "Josh" (my own user account) to do things. Other times I'm told I need permission from the "Administrators" group, which I'm in. Sometimes I get a vague "access is denied" message, without saying why.

The subfolders of the folder I'm trying to delete all have lock icons on them. After messing with their permissions for a bit I can get the locks to disappear, but still can't delete them or propagate permissions past them. Even if it worked I can't change each of the thousands of folders manually.

What's going on? What should I try next? How come, as an admin user, I can't take control of just any file?

  • 1
    Try the command prompt? – Vervious Jul 5 '10 at 16:55
  • 1
    @Nano, I was just about to say what a tremendously unhelpful comment that was... try doing WHAT at the command prompt? I already tried setting permissions from the command prompt using both icacls.exe and powershell, but neither did anything. But then I tried just one more thing, and it worked, so... thanks! :) – Josh Jul 5 '10 at 18:36
  • Er, you know it's Everyone, not Everybody, right? – Hello71 Jul 5 '10 at 19:15
  • er, right, I mean Everyone. (Fortunately Windows discourages you from giving permissions to nonexistent groups.) – Josh Jul 7 '10 at 14:34
  • yea my comment was pretty unhelpful. :) – Vervious Aug 5 '10 at 23:23

It is possible that the files are flagged Read-Only. This is an Attribute not an ACL, which can get confusing when figuring out what's going on. Attributes trump Rights. Checking the attributes on the file is pretty simple. Right click on the file/directory and go to Properties. It's on the bottom of the first tab. Under Win7 your options are "Read Only" and "Hidden". Clear the read-only button to make changes.

| improve this answer | |
  • I don't think that they were set read-only... anyway, some quick testing shows that windows lets me delete files AND change permissions on "read only" files without even giving a warning. (The only thing it seems I can't do is save over the file.) – Josh Jul 5 '10 at 18:32

Since changing the permissions wasn't working right, I tried to use icacls to do it from the command line. That didn't work. But then, on a whim, I tried using del. Specifically, del /f /s /q FolderName. That worked! Or at least, it deleted every file, and left the hierarchical structure of folders unchanged; but then windows let me delete that.

Does anyone know why 'del' would be able to delete files when windows explorer can't delete them or even properly set permissions on them?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.