6

I have a safari 14.0.1 problem on macOS 10.14.6

When I am running gmail or another app which needs attachments over safari, and I click on the paperclip icon in either app, the browser file select windows does not appear.

Things I have tried.

I can drag and drop a file to either app from a separate finder window and that works
I have tried firefox and the paperclip attachment icon works
I have tried a separate account and the paperclip icon does not work in safari there either, so it looks like a 'safari' thing rather than a 'my account' thing
I have deleted the cache and history from Safari and that changed nothing.

Anyone got any thoughts, please? Any ideas gratefully tried!

Thanks for your help in advance

1

The following fix worked for someone on my team. I am on the same Safari Version, 14.0.2 (15610.3.7.1.10, 15610), Catalina 10.15.7, but I do not have the issue and cannot test it directly, nor can I test on Safari 14.0.1.

  1. Enabling the Develop menu from "Safari->Preferences->Advanced->Show Develop menu in menu bar" (a checkbox).

  2. From the Develop menu, enabling "Disable Local File Restrictions".

0

My only thought is that a client has just called me with exactly the same problem. Like you, he has safari 14.0.1 problem on macOS 10.14.6. He's had the problem for the last couple of days. We tested this on GMail and OWA to confirm. Dragging files onto the message window to attach them still works, so it's something to do with the functionality of the paperclip button rather than disc access as such.

0

I am having the same issue as of this morning. I did the latest security update this AM. Works fine in a Chrome browser but not Safari. As Jason says - very annoying.

0

Between reading this Apple Communities thread and doing my own experimentation, I've learned that the problem...

  • is Safari-specific
  • affects Mojave and Catalina but not Big Sur
  • affects Safari 14.0.1 (released mid-November) and 14.0.2 (released mid-December). 14.0 is fine. As of this writing, there is no 14.0.3 yet.
  • affects clicking the paperclip/attachment button in Gmail, AOL Mail, Dropbox, and anything that brings up a Finder file-open dialog box.
  • does not affect Drag-n-Drop of files from Finder into Safari

So, until a future update fixes this bug, you can still attach files using Drag-n-Drop instead of the paperclip icon. Or you can use a different browser. Or you can upgrade to Big Sur.

Not the answer you're looking for? Browse other questions tagged or ask your own question.