0

I am running VMWare Player under Linux as an ordinary user with no sudo rights. Unfortunately the Player shows no USB devices. Also network inside guest machines does not work. I tried both creating a new virtual machine as well as starting an old one, copied from other computer.

Note: otherwise old machine works as expected and the new one boots properly from CD image.

I also tried to run VMPlayer as another user that has sudo rights as well as root using sudo vmplayer and the effect is the same.

As of network I tried both NAT and bridged one.

  1. How to make network and USB devices work?
  2. Can I run Player as normal user with no root privileges?
2
  • You need to somehow have Sudo permissions. You need to go to the VM settings and then Add USB. That certainly works in VMware Workstation with Admin Credentials. – John Nov 17 '20 at 23:39
  • Running as root does not help. It mus be something else. – Pawel Debski Nov 18 '20 at 19:42
0

I have finally pinpointed the problem.

I have both Virtual Box and VMWare Player installed. When I start VBox VM first VMPlayer finds neither network nor USB devices.

It is necessary to start first VMPlayer Virtual Machine first - it does than see network and USB devices correctly - and VBox VM only later on.

Virtual Box can than also find both network and USB devices,

I still have a problem with mounting pendrives in VMPlayer - the device gets disconnected after a while and no content is seen, but that's a story for another question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.