0

I'm trying to extend my home network to a second building close to my house. I've run a cat6 cable from my router (Google Wifi) to the second building, and when I jack it into my laptop everything seems fine - good ping & bandwith, no (apparent) packet loss. My goal is to add an old Asus router running Tomato, acting as a switch / wireless access point, like below:

# Current: directly to laptop (working)
modem           router          laptop
192.168.8.1  -> 192.168.86.1 -> 192.168.86.100

# Goal: via Asus access point 
# (not working... but is ok with much shorter router-AP cable)
modem           router          AP               laptop
192.168.8.1  -> 192.168.86.1 -> 192.168.86.10 -> 192.168.86.100

From the laptop I can ping the switch, but there seems to be a connectivity problem between the router and switch. The only solution was to move the Asus beside the router and use a different ethernet cable. Now it works. I can ping everything and internet is fine.

The difference between the two configurations is just the cable. The 'working' cable is about 1m long, and the 'not working' cable is long - maybe 30m/50m. Both are cat6. This is really interesting to me, I don't understand the hardware / physical characteristics of how this happens.

I'm looking for ideas as to why the cable apparently works fine when I remove that single hop, but doesn't work with the access point. Presumably the connection quality is not sufficient for the Google Wifi router and the Asus AP to see each other and maintain a good connection, but how can this be so and what can I do to improve?

3
  • "move the Asus beside the router and use a different Ethernet cable. Now it works. " <-- Did you try different ends on the longer cable? That is a likely reason. – John Nov 18 '20 at 2:17
  • Do you mean like crossover cable vs not? I didn't think that was a thing anymore. – Kirk Broadhurst Nov 18 '20 at 2:28
  • 2
    Modern network devices generally ignore crossover cable differences. I was thinking more in quality of cable end termination. Any error here causes issues and I just remake the ends. – John Nov 18 '20 at 2:29
0

After distracting myself with more tinkering and investigating, & dreading the potential cable work, I checked the ends per @John's suggestion. The end that I'd pushed through the wall was quite damaged - one of the plastic grooves which contain the copper connections was also collapsed, and it's very unlikely that all 8 plates were touching.

I took a sharp knife, ran it through each of the grooves, and realigned the plastic teeth or guides which separate each of the connectors. Only one was really problematic and almost folded over. Easy enough to straighten up.

I dropped it back into the device and immediately noticed that the LAN indicators in FreshTomato were now both green, instead of one green and one yellow, and the speed was now consistently 1000 instead of variously 10 or 100. I should have noticed these indicators earlier but what can you do.

Everything working perfectly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.