I downloaded VMware Player 16 the other day. The performance is better than VirtualBox, no doubt there. However, after the VM is started, as soon as the VMware BIOS screen pops up, I can't click on the menu bar (File, Edit, VM etc.), even if I press Ctrl+Alt. I can only navigate using the keyboard. I even tested older versions of Player (14 & 15) and some copies of Workstation Pro that my friend gave me to try, still the same issue, even with VMware Tools installed in the VMs.

It's worth noting that mouse integration in the VM works flawlessly, and if I press Ctrl+Alt I can use my host OS as normal.

After hours of searching for the issue, I found one older post on the VMware community (the only one that described exactly the same issue that I had), where the person who opened the topic stated that they downgraded from Workstation Pro 14 to 12 and that fixed their issue. I tried installing Workstation Pro 12 too, and the problem was solved.

I have absolutely no idea as to why Workstation Pro & Player versions 14+ have this issue. I've also read that these versions have some issues with other users, although they are minor. If anyone can shed light on this case it would be really appreciated.

Edit: Another user asked me below, but I can't seem to find the VMware Knowledgebase Article in my history. Sorry.

  • Player and Pro are very different.
    – essjae
    Nov 19 '20 at 18:59
  • To help debug the issue, it would help if you set your host and guest to use different mouse cursors. Then, when you try to click on the VMware Player menu bar, is it showing you the host mouse cursor or the guest cursor?
    – jamesdlin
    Dec 2 '20 at 9:00
  • @jamesdlin The host cursor. I downgraded to VMware Workstation 12 Pro and it works now. Thanks for commenting, by the way.
    – na-no.
    Dec 3 '20 at 15:13

Vmware Workstation V16 works fine with Virtual Machines. I have that setup here right now.

Make sure:

(1) That the current version of VMware Tools is installed on each machine. If you change versions of Player or Workstation too much, you may need to reinstall the Vmware Tools.

In normal operation with the Tools install, you do not need to use Ctrl Alt to change the mouse to the host. This makes me think the Tools are not installed or need to be reinstalled.

(2) Try using Player Workstation in windowed mode (not full screen) and have the Guest fit to the new window. After Tools have been reinstalled, check that Menus work.

(3) Post a Link (Edit your Question) to the Vmware Knowledgebase article that says downgrade to VMware V12.

If the above does not work, repairs need to be more aggressive.

(1) In each Guest (all Guests), uninstall Vbox Extensions and VMware Tools.

(2) Uninstall all Vbox apps and all Player / Workstations Apps (all versions).

(3) Assuming Windows 10, open cmd.exe with Run as Administrator and run in order:

dism.exe /online /cleanup-image /startcomponentcleanup

dism.exe /online /cleanup-image /restorehealth


Allow all this to finish.

Now pick the VMware Workstation product you wish to use, make sure you have a license Key, install it, and restart.

Open one Guest, install VMware Tools and test.

  • Requirements 1 & 2 were met while I was testing VMware Player 16, but no improvement there, I might have forgot to mention it. As for the 3rd one, I'm going to edit the question. Edit: I can't seem to find the link...
    – na-no.
    Nov 19 '20 at 19:20
  • I amended my answer with more steps. I have used Workstation for about 20 years and never had this issue.
    – John
    Nov 19 '20 at 19:46
  • Great. Thanks for the help. I'll run the system check later though since I'm in online class right now.
    – na-no.
    Nov 20 '20 at 8:20

I totally forgot about this post...

I just reinstalled Windows. A storage driver or something got really corrupt, the damage was irreparable. Backed up everything and reinstalled Windows, VMware Workstation 16 now works flawlessly. Plus, it got rid of some other minor nuisances, like having to Alt-Tab out of admin windows (like Task Manager) because I could not click out of them for some reason.

Man, if only reinstallations were so simple... (due to the fact that you may have to back up and then reinstall tens of programs and lots of data)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.