1

A single Windows 10 machine on our small office network will not connect to the internet or LAN when connected via a switch. It fails to see any network activity and reports there's no connection. This is a new(ish) PC that's worked perfectly for a month, then suddenly no longer connects. Nothing else has changed in that time.

               [Router]
                  |
               [Switch]
    ______________|________________
   |         |     |     |    |    |
 [PC]       Printers      Other PC's

However, when connected directly to the router it works perfectly:

   ┌----------  [Router]
   |               |
   |            [Switch]
   |         _____|________________
   |         |     |     |    |    |
 [PC]       Printers      Other PC's

I've tried the following things over the last few days based on internet searches:

  1. Reset the network setting using the Windows troubleshooter. The network icon in system tray shows a connection for a few seconds, then back to no connection. During that time a browser still cannot connect.
  2. Changed the ethernet cables
  3. Swapped the switch
  4. Activated wi-fi in the BIOS and used that - connects perfectly but is against company rules
  5. Swapped out the machine with a laptop, which works perfectly - this leads me to blame the machine
  6. Tried a different switch port

I've run out of things to try (my network experience is minimal) now. Any suggestions would be much appreciated.

The specifications for each machine:

  1. Router - ASUS RT-N66U
  2. Switch - Netgear GS316 - Unmanaged
  3. Windows PC Intel Ethernet Controller I225-V
5
  • Did you try the computer in another switch port? Do other Windows computers work on the switch?
    – John
    Nov 25, 2020 at 12:58
  • Thanks John. Updated.
    – EvilDr
    Nov 25, 2020 at 12:59
  • This is now a computer issue (other computers OK). Try (1) replacing / updating the Network Card driver. (2) TCP/IP Reset: Open cmd.exe with Run as Administrator (1) netsh int ip reset c:\resetlog.txt (2) ipconfig /flushdns (3) restart the computer
    – John
    Nov 25, 2020 at 13:06
  • I think you've solved it good Sir! Could you please migrate the comment as an answer? I'll monitor it for a few days then accept if we're all good. Many thanks.
    – EvilDr
    Nov 25, 2020 at 14:17
  • I have posted an answer for you. Thank you.
    – John
    Nov 25, 2020 at 14:28

1 Answer 1

1

Since we know from your tests, try both the following:

  1. Reinstall/Update the Network card driver.

  2. Do a TCP/IP reset, DNS Flush:

    Open cmd.exe with Run as Administrator.

     netsh int ip reset c:\resetlog.txt
     ipconfig /flushdns
    

    Restart the computer .

    This works for many situations.

2
  • Thank you. Some further investigation based on your answer reveals that there are many people having problems with the I225-V drivers and require firmware updates to fix
    – EvilDr
    Nov 25, 2020 at 15:23
  • I've had issues with that model part in the past. I recall having to install a compatible realtek driver rather than the Intel one due to some functional issues.
    – Arctiic
    May 11, 2023 at 20:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .