1

My laptop was not showing the wifi connectivity option. And i had just updated my network Adapter driver, so I assumed it must have been the problem. And after searching the net and making a few mistakes, i uninstalled my wifi network adapter driver completely.

I have no idea what driver was being used before and so I tried searching the internet.

I was able to find that my Wifi Network Adapter to be from Atheros, with these info Hardware Id : PCI\VEN_168C&DEV_0042

I am attaching the a picture of all the computer details, and operating system details.

Any help would be appreciated.enter image description here

enter image description here

  • 1
    Is there a reason you are still running Windows 10 version 1607? – Ramhound Nov 26 '20 at 15:09
  • @Ramhound the windows is not original and I have tried updating but it won't update. – user499096 Nov 26 '20 at 15:10
  • What exactly do you mean by "Windows is not original"? – Ramhound Nov 26 '20 at 15:21
  • You have installed the drives from the Dell website here? – Ramhound Nov 26 '20 at 15:42
  • You have a Qualcomm wireless network adapter, not an Atheros wireless network adapter. If your network adapter is not working then you are missing the Realtek drivers. You really should consider upgrading to the current version of Windows 10. – Ramhound Nov 26 '20 at 16:02
1

To reinstall your network adapter:

  • Go to Device Manager
  • Click on the Computer Icon at the top of the window (under 'Help') that is labelled 'Scan for hardware changes'
  • The network adapter should automatically reinstall itself.

Also, as Ramhound suggested, you really should update Windows. The current version of Windows you are on has been out of support since last year.

  • 1
    Thankyou for your help. But I followed Ramhound advice and upgraded windows via new installation. Thank you for time. – user499096 Nov 27 '20 at 5:31
  • No problem. You're welcome. – Virtuality Nov 27 '20 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.