0

So I am running into an issue with WSL not working as of recent.

When trying to launch WSL I get an error: Screenshot of the error

$ wsl
Please enable the Virtual Machine Platform Windows feature and ensure virtualization is enabled in the BIOS.
For information please visit https://aka.ms/wsl2-install

For BIOS I have confirmed Virtualization is on. At this point I am at a loss, I have tried a few different things that I found online and nothing seems to be working.


Update 1:

BIOS

Windows Features

6
  • 1
    You need to enable the Windows Hypervisor Platform. Please install it then update your screenshots
    – Ramhound
    Nov 26, 2020 at 20:49
  • 1
    Additionally, every single one of your screenshots, indicates that hardware virtualization is disabled. Where is the screenshot of your UEFI configuration?
    – Ramhound
    Nov 26, 2020 at 20:54
  • @Ramhound - Thank you for the quick response, I updated the post with some screenshots of my bios, and with the Hypervisor Platform turned on. I have since restarted and getting the same error.
    – Baker
    Nov 26, 2020 at 21:01
  • I have heard of a bug where the enabled status of VT- x was flipped. Additionally, Hyper-V isn’t required for WSL2, so I would uninstall it, and see if the Intel utility gives different results
    – Ramhound
    Nov 26, 2020 at 21:09
  • @Ramhound - Just tried that same thing in the Intel Utility and when launching WSL. CPU does show VT-x i.imgur.com/ax9fXHP.png
    – Baker
    Nov 26, 2020 at 21:33

1 Answer 1

0

I ended up solving this by updating my bios and that fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .