0

I created a script that does some processing on a page. Since Firefox started lazy loading pages this has caused some problems (the specific problems are irrelevant).

Is there any way to disable true lazy loading for Firefox? Ideally I could do this within the script or per site.

So, basically when I open a link in a background tab I want Firefox to not delay loading and formatting the page until I bring the tab to the foreground.

I’ve messed with some of the config and settings as explained here but nothing actually prevents lazy loading.

Now, it could be the script itself is somehow causing the page not to load. Essentially the script scrolls the window to load more content so I don't have to do it manually but it is always paused when the tab is not in view, so I have to watch it scroll and wait. So I can't just load the tab in the background and let the script scroll while I do other things.

3
  • Have you tried How to disable lazy loading in Firefox - TechRepublic?
    – DavidPostill
    Nov 28, 2020 at 18:17
  • @DavidPostill yes, of course, that is what I meant by modifying the config... none of it actually works. When I open a background tab or move to another one the loading stops for that tab because when I go back to it the page is not fully loaded, just continues from where I left it.
    – Stretto
    Nov 28, 2020 at 18:24
  • You say “…the specific problems are irrelevant…” but as a web developer myself, I find it odd you believe the specifics are irrelevant. If this is now default behavior, your script should accommodate that. Additionally, I cannot really image a situation where the page is in the background yet things need to be calculated. Maybe some kind of web page that gets update data via Ajax calls that somehow is paused by being in the background? In general I think your code needs to be refactored to accommodate this new behavior default in Firefox. Nov 28, 2020 at 18:49

2 Answers 2

1

I believe that the link you used is incorrect, that actually the item in about:config that needs disabling is dom.image-lazy-loading.enabled.

If this doesn't work for you, here are some add-ons that could help:

2
  • 1
    I had those set properly a long time ago... doesn't work. I tried Unlazy and it doesn't work. I think it might be the script itself is not being executed until the tab is visible. Not sure if it is tampermonkey or firefox that is doing this though.
    – Stretto
    Nov 28, 2020 at 20:35
  • Try the others.
    – harrymc
    Nov 28, 2020 at 20:36
0
  1. go to about:config
  2. search for “lazy”
  3. set the dom.image-lazy-loading.root-margin.bottom config to a very large number like 100,000,000.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .