2

I'm using fedora 32. I did sudo dnf update -y

I got below error -

    $ sudo dnf update -y
    Last metadata expiration check: 1:24:24 ago on Mon 30 Nov 2020 04:42:35 PM EST.
    Dependencies resolved.

    Problem: cannot install the best update candidate for package lutris-0.5.7.1-1.fc32.x86_64
    - nothing provides python3.8dist(python-magic) needed by lutris-0.5.8-1.fc32.x86_64
    =================================================================================================
    Package             Architecture        Version                      Repository            Size
    =================================================================================================
    Skipping packages with broken dependencies:
    lutris              x86_64              0.5.8-1.fc32                 updates              819 k

    Transaction Summary
    =================================================================================================
    Skip  1 Package

    Nothing to do.
    Complete!

I tried to install that package again -

    $ sudo dnf install PackageKit-glib
    Last metadata expiration check: 0:04:10 ago on Tue 01 Dec 2020 02:42:17 AM EST.
    Package PackageKit-glib-1.1.13-3.fc32.x86_64 is already installed.
    Package PackageKit-glib-1.1.13-3.fc32.i686 is already installed.
    Dependencies resolved.
    Nothing to do.
    Complete!

My operating system details are

$ lsb_release -a
LSB Version:    :core-4.1-amd64:core-4.1-noarch
Distributor ID: Fedora
Description:    Fedora release 32 (Thirty Two)
Release:        32
Codename:       ThirtyTwo

Below are the dteails about python version in my system -

    $ which python
    /usr/bin/python
    $ which python3
    /usr/bin/python3
    $ python --version
    Python 3.8.6
    $ python3 --version
    Python 3.8.6
    

How can I fix this above issue?

2
  • What is the result of which python? Dec 1, 2020 at 7:16
  • @Anaksunaman - updated the details about python/python3 inside the post. please let me know if you need any other details. Dec 1, 2020 at 7:40

1 Answer 1

1

I did sudo dnf remove PackageKit-glib -y and then the upgrade

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .